Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#10109 closed bug (duplicate)

IE7 removeAttr not functioning properly

Reported by: laurence.hoess@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.6.2
Keywords: Cc:
Blocked by: Blocking:

Description

Version: jQuery 1.6.2 (1.6.1 worked fine; jQuery Edge shows the same problem)

Browser: IE7 (Testing with IE8 in IE7 Mode) Works in FF 5.0.1 and IE8.

OS: Windows XP

Test Steps:

  1. Using the test case at http://jsfiddle.net/4erKM/14/
  1. Open IE8, hit F12, select Browser Mode: IE7.
  1. Select DACUM, a Duty, Task, and Step menus should appear with Task and Step menus disabled. Selecting a Duty should enable the Task menu, selecting a Task should enable the Step menu. However in IE7 those menus remain disabled.

This appears to be related to #9576.

Tried the .prop('disabled', false) workaround but that didn't resolve the problem.

Sample: http://jsfiddle.net/4erKM/14/

Change History (4)

comment:1 Changed 8 years ago by dmethvin

Resolution: invalid
Status: newclosed

That is a lot of code, but basically do not do this in script:

$("#duty").attr("disabled","disabled");
$("#task").removeAttr("disabled");

Instead do this:

$("#duty").prop("disabled", true);
$("#task").prop("disabled", false);

comment:2 Changed 8 years ago by Rick Waldron

Resolution: invalid
Status: closedreopened

comment:3 Changed 8 years ago by Rick Waldron

Resolution: duplicate
Status: reopenedclosed

comment:4 Changed 8 years ago by Rick Waldron

Duplicate of #9927.

Note: See TracTickets for help on using tickets.