Bug Tracker

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#10046 closed bug (duplicate)

fail when attr("disabled",false)

Reported by: gr0org Owned by:
Priority: low Milestone: None
Component: attributes Version: 1.6.2
Keywords: Cc:
Blocked by: Blocking:

Description

attr("disabled",true) is OK.
attr("disabled",false) is NG.
jquery-1.6.2 is NG.
jquery-1.6.1 is OK.

<html>
<head>
<script type="text/javascript" src="jquery-1.6.2.js"></script> 
<script type="text/javascript">
;$(function(){
	$("#b01").click(function(){
		$("#b02").attr("disabled",!$("#b02").attr("disabled"));
	});
});
</script> 
</head>
<body>
<div>
<input type="button" id="b01" value="b01" />
<input type="button" id="b02" value="b02" />
</div>
</body>
</html>

Change History (7)

comment:1 Changed 6 years ago by gr0org

IE7 is NG. FF is OK.

comment:2 Changed 6 years ago by anonymous

try to use prop() function instead of attr()...

comment:3 Changed 6 years ago by timmywil

Component: unfiledattributes
Priority: undecidedlow
Resolution: duplicate
Status: newclosed

comment:4 Changed 6 years ago by timmywil

Duplicate of #9719.

comment:5 in reply to:  2 Changed 6 years ago by gr0org

Replying to anonymous:

try to use prop() function instead of attr()...

Thanks. prop() is OK.

comment:6 in reply to:  3 Changed 6 years ago by gr0org

Replying to timmywil: Thanks.

comment:7 in reply to:  4 Changed 6 years ago by gr0org

Replying to timmywil:

Duplicate of #9719.

Thanks.

Note: See TracTickets for help on using tickets.