Bug Tracker

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#10034 closed bug (duplicate)

$(":button").attr('disabled', true) can not work in 1.6.2 but 1.6.1 is ok

Reported by: dankevin2tw@… Owned by:
Priority: low Milestone: None
Component: attributes Version: 1.6.2
Keywords: Cc:
Blocked by: Blocking:

Description

It takes log time and can't work in jquery-1.6.2.js , jquery-1.6.2.min.js It work successfully in jquery-1.6.1.js , jquery-1.6.1.min.js

Source Code :

<script language="javascript" type="text/javascript" src="jquery-1.6.2.js"></script>

<input id="A" type="button" value="TEST1" > <input id="B" type="button" value="TEST2" >

<div onClick="go();">Click it! </div> <script>

function go() {

$(":button").attr('disabled', true); $(":button").attr('disabled', false);

}

</script>

Change History (4)

comment:1 Changed 6 years ago by anonymous

Use IE8 browser

comment:2 Changed 6 years ago by anonymous

It takes long time

comment:3 Changed 6 years ago by timmywil

Component: unfiledattributes
Priority: undecidedlow
Resolution: duplicate
Status: newclosed

Everything is getting set properly, but we've had reports of IE not repainting. http://jsfiddle.net/timmywil/xWkdg/1/

comment:4 Changed 6 years ago by timmywil

Duplicate of #9719.

Note: See TracTickets for help on using tickets.