Bug Tracker

Ticket #9957 (closed bug: duplicate)

Opened 3 years ago

Last modified 2 years ago

setTimeout setInterval broken

Reported by: kimdwkimdw@… Owned by:
Priority: high Milestone: 1.next
Component: effects Version: 1.6.2
Keywords: Cc:
Blocking: Blocked by:

Description

Case A:


function a() {

obj.animate ( { } , speed ) setTimeout(a , 1000)

} setTimeout (a , 1000 ) ;


Case B:


function a() {

obj.animate ( { } , speed )

}

setInterval(a, 1000)


In both of cases, animation repeatedly stacked!

When I was seeing the other tab of chrome, I've got back to original page which has scripts like above. Browser ignore original duration of animation.

In IE9, it didn't appear. it appeared in Chrome, FF.

I've also tested this bug in 1.5.2, it didn't appear.

Change History

comment:1 Changed 3 years ago by anonymous

comment:2 Changed 3 years ago by timmywil

  • Priority changed from undecided to high
  • Resolution set to duplicate
  • Status changed from new to closed
  • Component changed from unfiled to effects
  • Milestone changed from None to 1.next

comment:3 Changed 3 years ago by timmywil

Duplicate of #9381.

Note: See TracTickets for help on using tickets.