Bug Tracker

Modify

Ticket #9636 (closed bug: duplicate)

Opened 3 years ago

Last modified 3 years ago

Duplicate body removes real body's background in Opera

Reported by: porneL (@… Owned by:
Priority: high Milestone: 1.next
Component: support Version: 1.6.1
Keywords: Cc:
Blocking: Blocked by:

Description

When page uses background on both <html> and <body>, this code:

// We use our own, invisible, body
…
documentElement.insertBefore( body, documentElement.firstChild );

causes Opera 10.50 to remove the background.

This breaks spritecow.com.

Per HTML5 spec <body> can exist only as the second element in the <html> element, so jQuery-generated DOM is invalid.

Change History

comment:1 Changed 3 years ago by anonymous

Oops, sorry — duplicate of #9420

comment:2 Changed 3 years ago by timmywil

  • Priority changed from undecided to high
  • Resolution set to duplicate
  • Status changed from new to closed
  • Component changed from unfiled to support

comment:3 Changed 3 years ago by timmywil

Duplicate of #9239.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.