Bug Tracker

Ticket #9634 (closed bug: fixed)

Opened 3 years ago

Last modified 3 years ago

visible "t" character in upper left corner during support.js init

Reported by: aet@… Owned by: rwaldron
Priority: high Milestone: 1.6.3
Component: support Version: 1.6.1
Keywords: Cc:
Blocking: Blocked by:

Description

Hi,

Ever since jQuery 1.4.3 release, there's been the following line in support.js:

div.innerHTML = "<table><tr><td style='padding:0;display:none'></td><td>t</td></tr></table>";

Does the visible t character have a specific purpose for the tests? I'm implementing a mobile html5 offline app and when the app gets reloaded, it shows the character on the screen, causing minor annoyance

Thanks, -Antti

Change History

comment:1 Changed 3 years ago by rwaldron

  • Owner set to jaubourg
  • Status changed from new to assigned

reassigning to jaubourg

Julian, can you take a look at this?

comment:2 Changed 3 years ago by timmywil

  • Priority changed from undecided to high
  • Component changed from unfiled to support

comment:3 Changed 3 years ago by jaubourg

I thought we had this fixed in an earlier release? What changed?

comment:4 Changed 3 years ago by john

  • Owner changed from jaubourg to aet@…
  • Status changed from assigned to pending

We're not seeing this on our end. Can you provide a test case or more specifics regarding the browser?

comment:5 Changed 3 years ago by aet@…

  • Status changed from pending to new

I've seen this behaviour with webkit (Safari 5, Chrome, iOS 4.3.x) but it's very rare and I barely get to see the character before it vanishes.

No proper test case in hand atm, I've seen this on lots of pages that generate all html/css code dynamically after $(document).ready and json loads.

I've disabled the 't' character from my own builds for now. Can you confirm that the character isn't a typo?

comment:6 Changed 3 years ago by rwaldron

  • Status changed from new to pending

Is this still an issue?

comment:7 Changed 3 years ago by aet@…

  • Status changed from pending to new

Yes, could someone please confirm that <td>t</td> isn't just a typo?

comment:8 Changed 3 years ago by rwaldron

  • Owner changed from aet@… to rwaldron
  • Status changed from new to assigned

No, it's not a typo. The comments in the source explain it's existence, though I think we can use a non-breaking-space to ensure the td doesn't collapse

comment:10 Changed 3 years ago by Dave Methvin

  • Status changed from assigned to closed
  • Resolution set to fixed

Merge pull request #444 from rwldrn/9634

Non-breaking-space should achieve the same effect as a visible character. Fixes #9634

Changeset: ea0303ecbf8e6b8a5c39bbad463e3e0d1dc84543

comment:11 Changed 3 years ago by dmethvin

  • Milestone changed from 1.next to 1.6.3

comment:12 Changed 3 years ago by Rick Waldron

Landing pull request 478. Apply fixes as noted by Diego Perini, David Murdoch & Mathias Bynens. Supplements #9634 Fixes #9634.

More Details:

comment:13 Changed 3 years ago by timmywil

#10180 is a duplicate of this ticket.

comment:14 Changed 3 years ago by Rick Waldron

Landing pull request 478. Apply fixes as noted by Diego Perini, David Murdoch & Mathias Bynens. Supplements #9634 Fixes #9634.

More Details:

Changeset: a42273807d2b1b1ff1362c1b9fc4cb48f65fda11

Note: See TracTickets for help on using tickets.