Bug Tracker

Ticket #9385 (closed enhancement: fixed)

Opened 4 years ago

Last modified 2 years ago

Deprecate jQuery.browser

Reported by: mako281@… Owned by: rwaldron
Priority: blocker Milestone: 1.8
Component: support Version: 1.6.1
Keywords: 1.8-discuss Cc:
Blocking: Blocked by:

Description

Add Google Chrome to jQuery.browser, that is all :)

Change History

comment:1 Changed 4 years ago by john

  • Keywords 1.7-discuss added

Nominating ticket for 1.7 discussion.

comment:2 Changed 4 years ago by rwaldron

-1, Adding new support to jQuery.browser might be perceived as encouragement to use it.

comment:3 Changed 4 years ago by jaubourg

-1,

comment:4 Changed 4 years ago by timmywil

-1, I wish jQuery.browser wasn't there.

comment:5 Changed 4 years ago by paul.irish

-1

(While I'm on the Chrome team, this is my personal opinion)

$.browser.safari was renamed to webkit a few versions ago to preempt this request.

comment:6 Changed 4 years ago by timmywil

  • Priority changed from undecided to low
  • Status changed from new to open
  • Component changed from unfiled to support

comment:7 Changed 4 years ago by dmethvin

+1, Gentlemen, what are our intentions with respect to jQuery.browser? If we are going to let it languish then let's just yank it with the reasoning that we aren't maintaining it anyway. The docs say it will be a supported plugin eventually. Will the plugin return Chrome?

comment:8 Changed 3 years ago by john

-1, I'd prefer to stop updating jQuery.browser

comment:9 Changed 3 years ago by addyosmani

-1

comment:10 Changed 3 years ago by ajpiano

+1, Totally agree with Dave here. If it's there, it should at least be sensible. Otherwise, let's actually get rid of the damn thing.

comment:11 Changed 3 years ago by scott.gonzalez

+0

comment:12 Changed 3 years ago by ThiefMaster

+1, sometimes there are browser bugs which are not testable through $.support

comment:13 Changed 3 years ago by rwaldron

  • Owner set to rwaldron
  • Status changed from open to assigned

comment:14 Changed 3 years ago by dmethvin

  • Priority changed from low to blocker
  • Milestone changed from 1.next to 1.7

comment:15 Changed 3 years ago by Dave Methvin

  • Status changed from assigned to closed
  • Resolution set to fixed

Merge pull request #417 from rwldrn/9385

Begrudgingly adds chrome detection to jQuery.browser (1.7). Fixes #9385

Changeset: 5417a2cf6b629b5bf3103454a5a6cab2181924e8

comment:16 Changed 3 years ago by Krinkle

What about Safari ? Now there's Chrome but no Safari, that's odd/annoying. Perhaps add back safari as well ?

comment:17 Changed 3 years ago by timmywil

Revert "Updated version numbers; Fixes #9385"

This reverts commit 09fe3ea265d730cc5e2dd2705d5a60ffd382d166.

Changeset: e2187f49637c62d9b72ec852c9213a20778e63d3

comment:18 Changed 3 years ago by timmywil

Revert "Begrudgingly adds chrome detection to jQuery.browser (1.7). Fixes #9385"

This reverts commit dd93d0eb32dc638ff3319792a885acd6d3c25c30.

Changeset: 2a045f8269de9ef936bfaa2efbf71b9962385cf8

comment:19 Changed 3 years ago by timmywil

  • Status changed from closed to reopened
  • Resolution fixed deleted

Reopened for 1.7.

comment:20 Changed 3 years ago by timmywil

  • Status changed from reopened to open

comment:21 Changed 3 years ago by rwaldron

  • Keywords 1.8-discuss added; 1.7-discuss removed
  • Milestone changed from 1.7 to 1.8

comment:22 Changed 3 years ago by mikesherov

+1, If we're going to have a jQuery.browser at all, it should be able to detect Chrome. This vote becomes a -1 if instead we decide to gut jQuery.browser completely.

comment:23 Changed 3 years ago by mikesherov

-1, Changing to -1 because I just saw that moving jQuery.browser to a compatibility plugin was up for a vote. :-)

comment:24 Changed 3 years ago by jaubourg

+0, if we move $.browser to an official plugin, then we can have this kind of change. Else, no.

comment:25 Changed 3 years ago by dmethvin

We voted this down in 1.7 but if we are planning to abandon maintenance of jQuery.browser we should determine a sunset version and get rid of it.

Our current docs say it will be turned into a plugin, I think the community's assumption would be that it is an official and maintained plugin. If we aren't going to maintain this we need to say so ASAP and provide other alternatives to avoid breaking code. (Although if it uses jQuery.browser it's already broken ... ba-dum-pum!)

comment:26 Changed 3 years ago by jzaefferer

-1, deprecated already anyway

comment:27 Changed 3 years ago by timmywil

-1, Never ever

comment:28 Changed 3 years ago by rwaldron

-1, still opposed.

comment:29 Changed 3 years ago by rwaldron

#11181 is a duplicate of this ticket.

comment:30 Changed 3 years ago by dmethvin

OK, we're keeping this in as-is for 1.8 but will trumpet that it is being removed into a plugin as of 1.9. It is already deprecated in the docs.

comment:32 Changed 3 years ago by dmethvin

  • Summary changed from Add Google Chrome to jQuery.browser to Deprecate jQuery.browser

There will be a separate  plugin as of 1.8, and jQuery.browser will disappear from core as of 1.9. You can include the plugin as of 1.8 if desired, or substitute your own flaky-and-fragile regex for our flaky-and-fragile regex, or (even better) just stop using browser sniffing.

comment:33 Changed 3 years ago by rwaldron

comment:34 Changed 3 years ago by dmethvin

There are some unit tests that need to use a different check, such as window.opera for jQuery.browser.opera.

comment:35 Changed 2 years ago by dmethvin

  • Status changed from open to closed
  • Resolution set to fixed

Duly and exhaustively deprecated. The jQuery.browser repo will be merged into the backcompat repo when it's created.

Note: See TracTickets for help on using tickets.