Bug Tracker

Modify

Ticket #9368 (closed bug: fixed)

Opened 3 years ago

Last modified 2 years ago

jQuery.camelCase() defined in css.js, but used more widely

Reported by: Steven Black Owned by: rwaldron
Priority: low Milestone: 1.6.2
Component: core Version: 1.6.1
Keywords: Cc:
Blocking: Blocked by:

Description

I just noticed that jQuery.camelCase() is defined in css.js but also invoked in data.js and effects.js.

In the interest of dependency management, jQuery.camelCase() should probably be defined more centrally, like in core.

Change History

comment:1 Changed 3 years ago by rwaldron

  • Priority changed from undecided to low
  • Status changed from new to open
  • Component changed from unfiled to core

I was patching a data-module issue that was directly caused by jQuery.camelCase() and felt it odd that I was writing tests in the data-module unit tests for a css-module function.

+1 to moving to core

comment:2 Changed 3 years ago by rwaldron

  • Owner set to rwaldron
  • Status changed from open to assigned

comment:3 Changed 3 years ago by timmywil

  • Milestone changed from 1.next to 1.6.2

comment:4 Changed 3 years ago by rwldrn

  • Status changed from assigned to closed
  • Resolution set to fixed

Landing pull request 383. Relocating jQuery.camelCase to core; Fixes #9368.

More Details:

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.