Bug Tracker

Ticket #9318 (closed bug: fixed)

Opened 3 years ago

Last modified 3 years ago

Calling data on a jQuery object with HTML5 data attributes has strange behaviour with if attribute names contain numbers.

Reported by: oliver.nightingale1@… Owned by: rwaldron
Priority: high Milestone: 1.6.3
Component: data Version: 1.6
Keywords: Cc:
Blocking: Blocked by:

Description

test case -  http://jsfiddle.net/BRv6U/1/

If any of the data attributes have numbers separated by hyphens they are missing from the returned object of data attributes.

Have been able to reproduce this bug in Chrome 13, FireFox 4. Safari 5.0.5 on OS X 10.6.7

Change History

comment:1 Changed 3 years ago by rwaldron

  • Owner set to rwaldron
  • Priority changed from undecided to high
  • Status changed from new to assigned
  • Component changed from unfiled to data

Confirmed.

comment:2 Changed 3 years ago by timmywil

#9487 is a duplicate of this ticket.

comment:3 Changed 3 years ago by john

Confirmed in bug triage.

comment:4 Changed 3 years ago by rwaldron

Further reduced test case:  http://jsfiddle.net/rwaldron/MZycX/

comment:5 Changed 3 years ago by Dave Methvin

  • Status changed from assigned to closed
  • Resolution set to fixed

Merge pull request #456 from rwldrn/9318

Improves support for arbitrary numbers in data keys. Fixes #9318

Changeset: b22c9046529852c7ce567df13397849e11e2b9cc

comment:6 Changed 3 years ago by dmethvin

  • Milestone changed from 1.next to 1.6.3
Note: See TracTickets for help on using tickets.