Bug Tracker

Modify

Ticket #8635 (closed bug: fixed)

Opened 3 years ago

Last modified 2 years ago

Firefox: uncaught exception at line 1285

Reported by: ruiz Owned by: rwaldron
Priority: blocker Milestone: 1.5.2
Component: support Version: 1.5.2rc1
Keywords: Cc:
Blocking: Blocked by:

Description

I'm getting this error in Firefox 3.6:

uncaught exception: [Exception... "Not enough arguments" nsresult: "0x80570001 (NS_ERROR_XPC_NOT_ENOUGH_ARGS)" location: "JS frame ::  http://domain.com/jquery-1.5.2rc1.js :: anonymous :: line 1285" data: no]

Adding null as a second argument for getComputedStyle() in line 1285 corrects it:

jQuery.support.reliableMarginRight = ( parseInt(document.defaultView.getComputedStyle(div,null).marginRight, 10) || 0 ) === 0;

Change History

comment:1 Changed 3 years ago by dmethvin

  • Priority changed from undecided to blocker
  • Component changed from unfiled to support
  • Milestone changed from 1.next to 1.5.2

comment:2 Changed 3 years ago by rwaldron

  • Owner set to rwaldron
  • Status changed from new to assigned

 https://github.com/jquery/jquery/pull/289

Adds null arg per recommendation

comment:3 Changed 3 years ago by john

  • Status changed from assigned to closed
  • Resolution set to fixed

Landed.

comment:4 Changed 3 years ago by rwaldron

#8626 is a duplicate of this ticket.

comment:5 Changed 3 years ago by jaubourg

Fixes #8635 again (fix was lost in rewrite). Also removes unnecessary "manual" garbage collection.

Changeset: 4344d0841756f8572c56490f12739ac204f40966

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.