Bug Tracker

Modify

Ticket #8566 (closed bug: duplicate)

Opened 3 years ago

Last modified 2 years ago

Possible Memory Leak in IE8 when loading jquery inside iframe

Reported by: jkang@… Owned by:
Priority: undecided Milestone: 1.next
Component: unfiled Version: 1.5.1
Keywords: Cc:
Blocking: Blocked by:

Description

I have included jquery 1.5.1 inside an iframe. The parent does a reload on this iframe and it causes ie8 memory to grow every time.

testmain.html :

<iframe id='ifrm' src='http://localhost:8080/acrm/test_iframe.html'></iframe>

<input type='button' value='RELOAD IFRAME' onclick='document.getElementById("ifrm").contentDocument.location.reload(true);'/>

test_iframe.html :

<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<script type='text/javascript' src="jscript/jquery-1.5.1.min.js"></script>
</head>
<body><div>This is the iframe</div></body>
</html>

Change History

comment:1 Changed 3 years ago by dmethvin

  • Status changed from new to closed
  • Resolution set to duplicate

comment:2 Changed 3 years ago by dmethvin

Duplicate of #7045.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.