Bug Tracker

Modify

Ticket #8418 (closed bug: fixed)

Opened 3 years ago

Last modified 2 years ago

set name parameter using attr() method in IE 7

Reported by: pra_dar@… Owned by:
Priority: high Milestone: 1.6
Component: attributes Version: 1.4.4
Keywords: Cc:
Blocking: Blocked by:

Description

Looks like attr("name","value") method is not working to set name attribute value in IE 7. It works fine in IE 8 and other browsers.

Test case:  http://jsfiddle.net/zRFnz/3/

Change History

comment:1 Changed 3 years ago by pra_dar@…

To provide more details on above ticket, somehow in IE 7 while setting name attribute it sets 'submitName' attribute and not 'name' attribute. Somehow IE 7 is not allowing to set name attribute dynamically.

comment:2 Changed 3 years ago by rwaldron

  • Priority changed from undecided to high
  • Status changed from new to open
  • Component changed from unfiled to attributes

Confirmed. This is due to a long standing issue in jQuery with regard to the difference between html attributes and element props.

Improved test:  http://jsfiddle.net/rwaldron/zRFnz/5/

comment:4 Changed 3 years ago by timmywil

  • Status changed from open to closed
  • Resolution set to fixed
  • Milestone changed from 1.next to 1.6

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.