Bug Tracker

Modify

Ticket #8397 (closed bug: duplicate)

Opened 3 years ago

Last modified 2 years ago

.hover + .clone(true) broken?

Reported by: cowboy Owned by: rwaldron
Priority: high Milestone: 1.next
Component: manipulation Version: 1.5.1
Keywords: Cc:
Blocking: Blocked by:

Description

Maybe this is a bug. Event callbacks bound with the .hover helper function don't seem to get copied over with a .clone(true).

 http://jsfiddle.net/cowboy/d6wm8/

(Tested in Chrome 10 beta)

Change History

comment:1 Changed 3 years ago by danheberden

  • Priority changed from undecided to high
  • Component changed from unfiled to manipulation

More specifically, mouseenter/mouseleave:  http://jsfiddle.net/danheberden/d6wm8/3/

Ben also asked about focusin, wrt possible events getting missed

Last edited 3 years ago by danheberden (previous) (diff)

comment:2 Changed 3 years ago by rwaldron

  • Owner set to rwaldron
  • Status changed from new to assigned

comment:3 Changed 3 years ago by dmethvin

Hmmm... Seems like *any* events attached via the special events API may not have their setup/teardown done properly unless they take the possibility of cloning into account. For example, #7340 (backed out in 1.5 for other reasons) was trying to remember the number of attaches so it could disconnect the event when it dropped to zero. That's gonna break if you clone elements.

comment:4 Changed 3 years ago by rwaldron

  • Status changed from assigned to closed
  • Resolution set to duplicate

comment:5 Changed 3 years ago by rwaldron

Duplicate of #7037.

comment:6 Changed 3 years ago by anonymous

same problem here. Hover events are not copied. As well as with 1.4.2 as with 1.5.2

comment:7 Changed 3 years ago by jaisonn

Same thing for me. I'm using quicksand to clone elements and then when I try to use the .hover on it, simply doesn't work.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.