Bug Tracker

Modify

Ticket #8135 (closed bug: fixed)

Opened 3 years ago

Last modified 2 years ago

ajax connection error not correctly handled in Firefox

Reported by: john.firebaugh Owned by: jaubourg
Priority: high Milestone: 1.5.1
Component: ajax Version: 1.5
Keywords: Cc:
Blocking: Blocked by:

Description

Configure a server to serve the following static page, and visit it in Firefox:

 https://gist.github.com/807090

Stop the server, then click the button.

Expected result: error alert.

Actual result: no alert is shown, and the following error is printed in the Firebug console:

uncaught exception: [Exception... "Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIXMLHttpRequest.getAllResponseHeaders]" nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)" location: "JS frame ::  http://0.0.0.0:3000/javascripts/jquery-1.5.js :: anonymous :: line 7207" data: no]

Change History

comment:1 Changed 3 years ago by john.firebaugh

Firefox version 3.6.13.

comment:2 Changed 3 years ago by jitter

  • Cc jaubourg added
  • Priority changed from undecided to high
  • Status changed from new to open
  • Component changed from unfiled to ajax

 http://bit.ly/e9l2Rz <-- description

 FF bug ticket <-- unfixed since 2004(!!)

comment:3 Changed 3 years ago by jaubourg

  • Owner set to jaubourg
  • Status changed from open to assigned

comment:4 Changed 3 years ago by jaubourg

  • Status changed from assigned to closed
  • Resolution set to fixed

Fixes #8135. Makes sure any exception thrown by Firefox when trying to access an XMLHttpRequest property when a network error occured is caught and notified as an error. Added test/networkerror.html to test the behavior.

Changeset: b90369e8cb2b6f3cc0afa34d815958ff0b605874

comment:5 Changed 3 years ago by adam@…

do you think it would make sense to make it a general try/catch block rather than specific to FireFox? Like the try/catch for Firefox above around setting the xhr.setRequestHeader?

But *THIS* patch is fantastic! Thank you *very* much for doing it.

comment:6 Changed 3 years ago by jitter

  • Cc jaubourg removed
  • Milestone changed from 1.next to 1.5.1

comment:7 Changed 3 years ago by jitter

#8400 is a duplicate of this ticket.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.