Bug Tracker

Modify

Ticket #8129 (closed bug: fixed)

Opened 3 years ago

Last modified 2 years ago

Cloning <select multiple> selected items incorrect in IE8

Reported by: aaronbarker Owned by: rwaldron
Priority: blocker Milestone: 1.5.1
Component: manipulation Version: 1.5
Keywords: regression Cc:
Blocking: Blocked by:

Description

 http://jsfiddle.net/aaronbarker/VSnzy/2/

The selected options are not cloned correctly. Options 2/4/6 should be selected, but in the clone only 6 is selected

This was working in 1.4.4  http://jsfiddle.net/aaronbarker/HJ3Wf/1/

Change History

comment:1 Changed 3 years ago by jitter

  • Priority changed from undecided to high
  • Status changed from new to open
  • Component changed from unfiled to manipulation
  • Milestone changed from 1.next to 1.5.1

comment:2 Changed 3 years ago by dmethvin

It's due to the order that we call cloneFixAttributes. First we fix the attributes of all the descendants, then we fix the attrs of the parent. After the descendants are fixed everything looks good. However, when fixing the cloned parent it calls clearAttributes; that removes the multiple attribute and only leaves the last selected option standing.

comment:3 Changed 3 years ago by jitter

  • Priority changed from high to blocker

comment:4 Changed 3 years ago by jitter

  • Keywords regression added

comment:6 Changed 3 years ago by rwaldron

  • Owner set to rwaldron
  • Status changed from open to assigned

comment:7 Changed 3 years ago by rwldrn

  • Status changed from assigned to closed
  • Resolution set to fixed

Fixes #8129. Fix cloning multiple selected options in IE8.

Changeset: fa4c90987fc9aede4de3f41976cda91acad81736

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.