Bug Tracker

Modify

Ticket #7862 (closed bug: fixed)

Opened 3 years ago

Last modified 2 years ago

jQuery.globalEval(): Execution Delayed By Remote Scripts in Firefox

Reported by: serverherder Owned by: rwaldron
Priority: low Milestone: 1.6
Component: core Version: 1.4.4
Keywords: Cc:
Blocking: Blocked by:

Description

This page demonstrates the issue. A remote script with a 5 second delay is inserted immediately before the call to globalEval(). In firefox <=3.6, the globalEval() script will not execute until the remote script is complete.

 http://jsfiddle.net/serverherder/58te4/2/embedded/result/

For Firefox 3.6, a work around exists. On the globalEval()'d script element, set the async property to true and embed the script text using data-uri. While it does not trigger synchronous execution, it does circumvent any delays caused by long polling remote scripts.

 http://jsfiddle.net/serverherder/dTgm5/1/embedded/result/

This was suggested here:  http://forum.jquery.com/topic/prevent-globaleval-delays-in-firefox-using-async-data-uri

Change History

comment:1 Changed 3 years ago by rwaldron

  • Priority changed from undecided to low
  • Component changed from unfiled to core
  • Milestone 1.next deleted

comment:2 Changed 3 years ago by rwaldron

  • Owner set to rwaldron
  • Status changed from new to assigned

comment:3 Changed 3 years ago by jaubourg

#4545 is a duplicate of this ticket.

comment:4 Changed 3 years ago by john

  • Status changed from assigned to closed
  • Resolution set to fixed
  • Milestone set to 1.6

This is resolved in 1.6 as we're no longer using an injected script node.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.