Bug Tracker

Modify

Ticket #7776 (closed bug: duplicate)

Opened 3 years ago

Last modified 2 years ago

empty tbody not found in jQuery 1.4.4

Reported by: anonymous Owned by:
Priority: high Milestone: 1.5
Component: selector Version: 1.5
Keywords: Cc:
Blocking: Blocked by:

Description

hi,

i have a table like:

<table>
  <thead>
    ...
  </thead>
  <tbody></tbody>
</table>

in jQuery 1.4.4, if i have 'thead' as jQuery object, the following does not find the table body:

$('tbody', head.parent());

i also tested in 1.4.3 and 1.4.2, in this versions everything works as expected.

i used FF3.6, not tested in other browsers

regards

Change History

comment:1 follow-up: ↓ 2 Changed 3 years ago by jitter

  • Status changed from new to closed
  • Resolution set to worksforme

Thanks for taking the time to contribute to the jQuery project by writing a bug report.

After checking your report I made up this  test case, but I can't reproduce your problem. This seems to work fine for me. Closing for now.

Please report back if you can provide a test case which reproduces your problem.


 How to report bugs

comment:2 in reply to: ↑ 1 Changed 3 years ago by anonymous

Replying to jitter:

Thanks for taking the time to contribute to the jQuery project by writing a bug report.

After checking your report I made up this  test case, but I can't reproduce your problem. This seems to work fine for me. Closing for now.

Please report back if you can provide a test case which reproduces your problem.


 How to report bugs

here you go

 http://jsfiddle.net/32H2F/10/

regards

comment:3 Changed 3 years ago by jitter

  • Priority changed from undecided to high
  • Resolution worksforme deleted
  • Status changed from closed to reopened
  • Component changed from unfiled to selector
  • Milestone changed from 1.next to 1.4.5

Thanks for reporting back with a the test case. This has already been fixed in the current dev-version

Your  test case using jquery-git version.

comment:4 Changed 3 years ago by jitter

  • Status changed from reopened to closed
  • Resolution set to duplicate

comment:5 Changed 3 years ago by jitter

Duplicate of #7533.

comment:6 Changed 3 years ago by john

  • Version changed from 1.4.4 to 1.5

There wasn't a 1.4.5 release, was actually 1.5.

comment:7 Changed 3 years ago by john

  • Milestone changed from 1.4.5 to 1.5

There was no 1.4.5 release, was actually 1.5.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.