Bug Tracker

Ticket #7699 (closed bug: duplicate)

Opened 4 years ago

Last modified 4 years ago

submit() will not submit a form with a submit input named 'submit'

Reported by: gmo Owned by:
Priority: undecided Milestone: 1.6
Component: unfiled Version: 1.4.4
Keywords: Cc:
Blocking: Blocked by:

Description

  1. jQuery 1.4.4 min, others
  2. Chrome 8.0.552.208 beta, Linux x86; Firefox 3.6.12, Linux x86.

Calling submit() on a form with <input type="submit" name="submit"> should submit the form, but does not. Changing the name attribute to anything else causes submit() to function properly.

 http://is.gd/i9Prq for example

Change History

comment:1 Changed 4 years ago by danheberden

comment:2 Changed 4 years ago by danheberden

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #1414, #6264

Note: See TracTickets for help on using tickets.