Bug Tracker

Ticket #7634 (closed bug: duplicate)

Opened 4 years ago

Last modified 4 years ago

Can't find "option" in "select" with a point within id.

Reported by: xguell@… Owned by:
Priority: high Milestone: 1.5
Component: selector Version: 1.4.4
Keywords: Cc:
Blocking: Blocked by:

Description

When there's a point in the id of a select, val(x) doesn't work.

Debugging it I can see that no "option" in a select with a point in id (ex: "test.test1") is retrieved with "find".

Test case:  http://jsfiddle.net/WM2gA/

Note that it works with jQuery 1.4.2 and 1.4.3.

Change History

comment:1 Changed 4 years ago by jitter

  • Priority changed from undecided to high
  • Resolution set to duplicate
  • Status changed from new to closed
  • Component changed from unfiled to selector

Thanks for taking the time to contribute to the jQuery project by writing a bug report and providing a testcase!

As this is already a known issue I'm closing this bug.

comment:2 Changed 4 years ago by jitter

Duplicate of #7533.

Note: See TracTickets for help on using tickets.