Bug Tracker

Ticket #7505 (closed bug: duplicate)

Opened 4 years ago

Last modified 4 years ago

document.bind('selectstart') and attr() problem

Reported by: dmifedorenko@… Owned by:
Priority: undecided Milestone: 1.5
Component: unfiled Version: 1.4.4
Keywords: Cc:
Blocking: Blocked by:

Description

Test case  http://jsfiddle.net/Z3bkE/ return empty string on 1.4.4, but on <=1.4.3 it returns 1.

Because of this bug popular jQuery.event.drag library dont work with 1.4.4.

Any way to fix it?

Change History

comment:1 Changed 4 years ago by jitter

Potential duplicate of #7500

comment:2 Changed 4 years ago by SlexAxton

  • Status changed from new to closed
  • Resolution set to duplicate

Correct, jitter, it seems to be a symptom of a regression on attr on non-dom nodes.

A workaround for people doing this now would be to use the 'body' element instead of document:  http://jsfiddle.net/Z3bkE/1/

I'll mark this as a dupe though. thanks Jitter for the catch.

comment:3 Changed 4 years ago by SlexAxton

Duplicate of #7500.

Note: See TracTickets for help on using tickets.