Bug Tracker

Modify

Ticket #7408 (closed bug: duplicate)

Opened 3 years ago

Last modified 2 years ago

Attribute selector in "is" not working in firefox

Reported by: mcm.ham@… Owned by:
Priority: high Milestone: 1.5
Component: attributes Version: 1.4.4rc
Keywords: Cc:
Blocking: Blocked by:

Description

 http://jsfiddle.net/Y3gW8/

Should be true in Firefox, works in other browsers and in Firefox for 1.4.2.

Change History

comment:1 Changed 3 years ago by jitter

The documentation for  attribute-selectors says:

Attribute values in selector expressions can be written as bare words and must be surrounded by quotation marks.

So if you do that and change your test accordingly to use quotation marks around the attribute value it works in all browsers.

 test case

Last edited 3 years ago by jitter (previous) (diff)

comment:2 Changed 3 years ago by mcm.ham@…

Thanks, that helps. I guess I've just got into the habit of not using quotes coming from working with css where it appears to be optional in the standard, and until now has worked fine in jquery.

 http://www.w3.org/TR/CSS2/selector.html#attribute-selectors

This bug can probably be marked as invalid.

comment:3 Changed 3 years ago by rwaldron

  • Priority changed from undecided to high
  • Resolution set to duplicate
  • Status changed from new to closed
  • Component changed from unfiled to attributes

comment:4 Changed 3 years ago by rwaldron

Duplicate of #7295.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.