Bug Tracker

Modify

Ticket #7393 (closed bug: fixed)

Opened 3 years ago

Last modified 3 years ago

Elements hidden before appended to the DOM can't be shown

Reported by: bentruyman Owned by:
Priority: blocker Milestone: 1.4.4
Component: effects Version: 1.4.4rc
Keywords: regression Cc:
Blocking: Blocked by:

Description

Worked before:

$('<div>').hide().appendTo('body').show();

It works if hide()is called after the appendTo. Seems like this could be a blocker as I often create elements, hide them before appending them, and once ready show it.

See:  http://jsfiddle.net/nxwAq/

Tested and not working in: Chrome 8, Safari 5, Opera 10.63

Seems fine in FF 3.6 & 4 though.

Change History

comment:1 Changed 3 years ago by snover

  • Keywords regression added
  • Priority changed from undecided to blocker
  • Status changed from new to open
  • Component changed from unfiled to effects
  • Milestone changed from 1.5 to 1.4.4

Works fine in 1.4.3. Probably a regression from [9d1bfeb7ffe63b5a7488929b7be847bc1a00f6a6] since olddisplay is being set to “auto”, whereas it used to be empty string.

comment:2 Changed 3 years ago by jeresig

  • Status changed from open to closed
  • Resolution set to fixed

Limit the scope of the CSS 'auto' change to just height/width. Fixes #7393.

Changeset: d9478954b9de79a7f3538e935bfd98cdc61ee435

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.