Bug Tracker

Modify

Ticket #7243 (closed bug: fixed)

Opened 4 years ago

Last modified 2 years ago

live is not working properly with attribute not equal selector in Firefox

Reported by: anonymous Owned by: john
Priority: blocker Milestone: 1.4.4
Component: selector Version: 1.4.3
Keywords: live focusout regression Cc:
Blocking: Blocked by:

Description

Using live focusout do not fire any event on firefox mac 3.6, work on IE and webkit

Change History

comment:1 Changed 4 years ago by addyosmani

  • Keywords live focusout added
  • Owner set to anonymous
  • Status changed from new to pending
  • Priority changed from undecided to low

Can you please submit a valid testcase reproducing this issue (ideally on jsFiddle) so that we can evaluate the bug mentioned?

comment:2 Changed 4 years ago by cedric_dugas@…

Finally the problem comes from Sizzle I think,

 http://www.jsfiddle.net/HngRv/1/

when .not(":checkbox") is added, the script do not work,

but $("[class*=validate]") will work.

comment:3 Changed 4 years ago by anonymous

  • Status changed from pending to new

In fact,

Doing more tests, it seems this do nto work anywhere,

But this work everywhere beside firefox

$("[class*=validate][type!=checkbox]").live("focusout", function(){ alert(""); })

comment:4 Changed 4 years ago by cedric_dugas@…

The url of that version:  http://www.jsfiddle.net/HngRv/4/

Sorry for the spam....

comment:5 Changed 4 years ago by snover

  • Status changed from new to open
  • Component changed from unfiled to selector
  • Summary changed from live focusout is not working on input element on Firefox 3.6 to live is not working properly with attribute not equal selector in Firefox
  • Priority changed from low to blocker
  • Milestone changed from 1.5 to 1.4.4
  • Keywords regression added

This has nothing to do with the event type and everything to do with live + attribute not-equals selector.  revised test case This also happens in Firefox 4. All other browsers pass. This is a regression from 1.4.2.

comment:6 Changed 4 years ago by rwaldron

attribute not-equals selector is also broken in http://bugs.jquery.com/ticket/7216

comment:7 Changed 4 years ago by snover

#7216 is a duplicate of this ticket.

comment:8 Changed 4 years ago by snover

Firefox fails to throw an Error when matchesSelector is passed an invalid selector string and instead just raises a warning (like what happens when you give it invalid CSS). This was already worked around with custom pseudo-selectors, but attribute not-equals is also not a valid CSS selector and so fails.

comment:9 Changed 4 years ago by snover

  • Owner changed from anonymous to snover
  • Status changed from open to accepted

comment:10 Changed 4 years ago by snover

comment:11 Changed 4 years ago by snover

  • Status changed from accepted to new

comment:12 Changed 4 years ago by snover

  • Status changed from new to assigned

comment:13 Changed 4 years ago by john

  • Owner changed from snover to john

comment:14 Changed 4 years ago by jeresig

  • Status changed from assigned to closed
  • Resolution set to fixed

Adding another test for an issue in Gecko's matchesSelector implementation. Fixes #7243.

Changeset: 9be7461c3c7e85b1995766533db8806eb0909779

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.