Bug Tracker

Modify

Ticket #7220 (closed bug: fixed)

Opened 4 years ago

Last modified 2 years ago

Next Sibling combined with :last is failing.

Reported by: marioestrada Owned by: john
Priority: blocker Milestone: 1.4.4
Component: selector Version: 1.4.3
Keywords: regression Cc:
Blocking: Blocked by:

Description

At techspot.com I have a selector that runs after more stories have been loading using ajax and where the page should scroll to the first loaded story, but with 1.4.3 it is no longer working.

The selector is '.next_page:last + .headline_story' it used to work on 1.4.2 but not anymore, it doesn't find any objects. Using the alternative $('.next_page:last').next('.headline_story') works but still I think this is a bug since it used to work.

Change History

comment:1 Changed 4 years ago by marioestrada

Here is a test case:  http://jsfiddle.net/Xy9GL/ with the + selector not working.

And working using .next():  http://jsfiddle.net/n5Nh5/1/

comment:2 Changed 3 years ago by snover

  • Keywords regression added
  • Priority changed from undecided to blocker
  • Status changed from new to open
  • Component changed from unfiled to selector

comment:3 Changed 3 years ago by cowboy

I threw together this tiny plugin to help debug issues like this:  http://gist.github.com/640714

See it in use here:  http://jsfiddle.net/cowboy/skGZx/

Last edited 3 years ago by cowboy (previous) (diff)

comment:4 Changed 3 years ago by cowboy

Also, the link in my last comment has a bunch of test cases that fail in 1.4.3 but work in 1.4.2 - please add more!

comment:5 Changed 3 years ago by snover

  • Owner set to ajpiano
  • Status changed from open to assigned

comment:6 Changed 3 years ago by ajpiano

  • Owner changed from ajpiano to john

comment:7 Changed 3 years ago by jeresig

  • Status changed from assigned to closed
  • Resolution set to fixed

Make sure that +, >, ~ leading, rooted, selectors go to the old engine. Thanks to @rkatic for the catch! Fixes #7220.

Changeset: 424500bcf068a234b13cd9ef33d94580c35eeb86

comment:8 Changed 3 years ago by john

#7277 is a duplicate of this ticket.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.