Bug Tracker

Ticket #7219 (closed bug: fixed)

Opened 4 years ago

Last modified 3 years ago

.children(selector) no longer works in 1.4.3

Reported by: anonymous Owned by: dmethvin
Priority: blocker Milestone: 1.4.4
Component: selector Version: 1.4.3
Keywords: children regression Cc:
Blocking: Blocked by:

Description

without selector .children() works, but using a selector like "#abc" return an empty object.

Change History

comment:1 follow-ups: ↓ 5 ↓ 17 Changed 4 years ago by addyosmani

  • Keywords children added
  • Status changed from new to closed
  • Resolution set to worksforme

This is working fine with both jQuery 1.4.3 and 1.4.2 as per this test case:  http://jsfiddle.net/addyosmani/z6XBx/. If you are able to submit a test case which fails using the submitted description we will re-evaluate this ticket.

comment:2 Changed 4 years ago by anonymous

test case:  http://jsfiddle.net/z6XBx/2/ but replacing the first "children" by a "find" and it works.

comment:3 Changed 4 years ago by anonymous

delete "node" tags in html and the test case works.

comment:4 Changed 4 years ago by anonymous

just deleting "<instance_node url="#default"/>" and "<instance_camera url="#Home-camera"/>" in the test case html and it works like expected. so it seems the problem comes from here ?

comment:5 in reply to: ↑ 1 ; follow-up: ↓ 6 Changed 4 years ago by anonymous

Replying to addyosmani:

This is working fine with both jQuery 1.4.3 and 1.4.2 as per this test case:  http://jsfiddle.net/addyosmani/z6XBx/. If you are able to submit a test case which fails using the submitted description we will re-evaluate this ticket.

I work to isolate the problem: see  http://jsfiddle.net/z6XBx/5/ in 1.4.2 return 1 in 1.4.3 return 0

comment:6 in reply to: ↑ 5 Changed 4 years ago by anonymous

Replying to anonymous:

Replying to addyosmani:

This is working fine with both jQuery 1.4.3 and 1.4.2 as per this test case:  http://jsfiddle.net/addyosmani/z6XBx/. If you are able to submit a test case which fails using the submitted description we will re-evaluate this ticket.

I work to isolate the problem: see  http://jsfiddle.net/z6XBx/5/ in 1.4.2 return 1 in 1.4.3 return 0

here a clearer test case:  http://jsfiddle.net/z6XBx/6/ 1.4.2 return 1 (good) 1.4.3 return 0 (bad)

comment:7 Changed 4 years ago by snover

#7251 is a duplicate of this ticket.

comment:8 follow-ups: ↓ 10 ↓ 11 Changed 4 years ago by snover

  • Status changed from closed to reopened
  • Resolution worksforme deleted

Chrome 6 and Safari 3 fail. All other browsers pass. jQuery doesn’t guarantee support for XML, however, so this may be a wontfix.

Last edited 4 years ago by snover (previous) (diff)

comment:9 Changed 4 years ago by snover

  • Keywords needsreview regression added
  • Priority changed from undecided to blocker
  • Component changed from unfiled to selector

comment:10 in reply to: ↑ 8 Changed 4 years ago by anonymous

Replying to snover:

Chrome 6 and Safari 3 fail. All other browsers pass. jQuery doesn’t guarantee support for XML, however, so this may be a wontfix.

chromium 7.0.517.41 (62167) Ubuntu 10.04 fail too.

comment:11 in reply to: ↑ 8 Changed 4 years ago by anonymous

Replying to snover:

Chrome 6 and Safari 3 fail. All other browsers pass. jQuery doesn’t guarantee support for XML, however, so this may be a wontfix.

'wontfix' would be unfortunate because it worked fine in 1.4.2

comment:12 Changed 4 years ago by anonymous

completing test case:  http://jsfiddle.net/z6XBx/9/ show that chidren() bug but that find().get(0) works.

comment:13 Changed 4 years ago by dmethvin

  • Owner set to dmethvin
  • Status changed from reopened to assigned

comment:14 Changed 4 years ago by dmethvin

Simpler test case:  http://jsfiddle.net/scvza/

comment:15 Changed 4 years ago by jeresig

  • Status changed from assigned to closed
  • Resolution set to fixed

Make sure that we don't use matchesSelector on XML Documents (same as with qSA). Fixes #7219.

Changeset: 6bc30425f6d3c9c1eaddacc5d08bb29a4a0636ca

comment:16 Changed 4 years ago by dmethvin

  • Keywords needsreview removed

comment:17 in reply to: ↑ 1 Changed 3 years ago by anonymous

Replying to addyosmani:

This is working fine with both jQuery 1.4.3 and 1.4.2 as per this test case:  http://jsfiddle.net/addyosmani/z6XBx/. If you are able to submit a test case which fails using the submitted description we will re-evaluate this ticket.

I create a test at  http://jsfiddle.net/z4Jqy/1/

Note: See TracTickets for help on using tickets.