Bug Tracker

Modify

Ticket #7195 (closed enhancement: fixed)

Opened 4 years ago

Last modified 2 years ago

Ajax rewrite

Reported by: jaubourg Owned by:
Priority: blocker Milestone: 1.5
Component: ajax Version: 1.4.3
Keywords: needsreview Cc: rwaldron, john, paul.irish
Blocking: #3342, #4964, #6703, #7289 Blocked by: #5154, #6778

Description

I made a pull request for an ajax rewrite revamping the architecture into a pluggable one and more.

I've been keeping the source in sync with latest version here:  http://github.com/jaubourg/jquery

I opened a pull request for code review here:  http://github.com/jquery/jquery/pull/45

And I have a write-up describing the new architecture and new features here:  http://oksoclap.com/6Y26bm1ZsB

Change History

comment:1 Changed 4 years ago by snover

  • Priority changed from undecided to high
  • Status changed from new to open
  • Component changed from unfiled to ajax
  • Milestone changed from 1.4.3 to 1.next

comment:2 Changed 4 years ago by dmethvin

Yay, we finally have a ticket for this!

I have a feeling that a change this big can't get into core until 1.5; you saw that John had to back out the 1.4.3 change of moving ajax-related functions under jQuery.ajax.

comment:3 Changed 3 years ago by snover

  • Milestone changed from 1.4.4 to 1.5

Retarget all enhancements/features to next major version.

comment:4 Changed 3 years ago by snover

  • Blocking 7289 added

comment:5 Changed 3 years ago by snover

  • Blocking 3342 added

comment:6 Changed 3 years ago by rwaldron

  • Cc rwaldron added

comment:7 Changed 3 years ago by rwaldron

  • Blocking 6703 added

comment:8 Changed 3 years ago by dmethvin

  • Blocking 4964 added

comment:9 Changed 3 years ago by addyosmani

  • Cc john added
  • Keywords needsreview added

comment:10 Changed 3 years ago by paul.irish

  • Cc paul.irish added

comment:11 Changed 3 years ago by snover

  • Blocked by 6778 added

(In #6778) Currently, we don’t even try to divine the type of the returned data (except for XML) until after dataFilter has already happened.

This can probably happen along with the AJAX rewrite.

comment:12 Changed 3 years ago by snover

  • Blocked by 5154 added

(In #5154) Truly, the behaviour of $.fn.load is in a bizarre class of its own. Rather than providing a mechanism for switching between GET and POST, we should probably just revisit the logic of the method itself to begin with.

comment:13 Changed 3 years ago by jaubourg

  • Status changed from open to closed
  • Resolution set to fixed

Rewrite of the Ajax module by Julian Aubourg. Some (dated) details can be found here:  http://oksoclap.com/6Y26bm1ZsB more details are forthcoming. Fixes #7195.

Changeset: ab3ba4a81252c4357a7aab5f24d765d41d47986e

comment:14 Changed 3 years ago by snover

#7734 is a duplicate of this ticket.

comment:15 Changed 3 years ago by john

  • Priority changed from high to blocker

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.