Bug Tracker

Ticket #6514 (closed bug: fixed)

Opened 4 years ago

Last modified 4 years ago

Mouseenter and mouseleave events not able to be triggered if bound by live

Reported by: brianloveswords Owned by:
Priority: high Milestone: 1.6
Component: event Version: 1.4.2
Keywords: mouseenter, mouseleave, live, trigger Cc:
Blocking: Blocked by:

Description

If mouseenter and mouseleave are bound by live, $.trigger() will not activate them. However if they are bound by $.bind(), they are triggerable.

I've attached a patch including QUnit tests to prove existence, and the fix. You can see the commit here:  http://github.com/brianlovesdata/jquery/commit/5f816ffca67e7fdcedcff580d19c4a7d7994c48a

Attachments

live-event-trigger-fix.patch Download (1.4 KB) - added by brianloveswords 4 years ago.
QUnit test and fix for mouseenter and mouseleave not being triggerable when bound by live.

Change History

Changed 4 years ago by brianloveswords

QUnit test and fix for mouseenter and mouseleave not being triggerable when bound by live.

comment:1 Changed 4 years ago by matdumsa

I experienced the same issue. Thanks for the patch, hope it gets in 1.4.3

comment:2 Changed 4 years ago by rwaldron

  • Priority set to high
  • Status changed from new to open
  • Milestone 1.4.3 deleted

comment:3 Changed 4 years ago by rwaldron

#6880 is a duplicate of this ticket.

comment:4 Changed 4 years ago by rwaldron

#7756 is a duplicate of this ticket.

comment:5 Changed 4 years ago by john

  • Milestone set to 1.6

comment:6 Changed 4 years ago by Brian Brennan

  • Status changed from open to closed
  • Resolution set to fixed

Fix live mouseenter and mouseleave binding so they can be activated by triggers. Fixes #6514.

Changeset: d46042e0500fb8241bf5ba012dfc779b535aa5fe

comment:7 Changed 4 years ago by Brian Brennan

Fix live mouseenter and mouseleave binding so they can be activated by triggers. Fixes #6514.

Changeset: 3cb9c1835c0382163b2e94ae626a7ae0d2d0d94f

comment:8 Changed 4 years ago by rwaldron

For bookkeeping purpose:

DRY out #6514;

Changeset:  8d3754751dfa348c1d1e2d6735ec8cbc3a404695

Note: See TracTickets for help on using tickets.