Bug Tracker

Ticket #6330 (closed bug: duplicate)

Opened 5 years ago

Last modified 4 years ago

'checked' attribute does not get rendered to string

Reported by: ben.page Owned by:
Priority: Milestone: 1.4.3
Component: attributes Version: 1.4.2
Keywords: checkbox checked Cc:
Blocking: Blocked by:

Description

var obj = $("<input>").attr({

type: "checkbox", checked: true

});

creates a checkbox object which is checked. If you render that object to a string you only get

<input type="checkbox" />

you do not get checked="checked"

Change History

comment:1 Changed 5 years ago by ben.page

in order to render to a string i use:

var str = $('<div>').append(obj).remove().html();

comment:2 Changed 4 years ago by dmethvin

  • Status changed from new to closed
  • Resolution set to duplicate

The "checked" is a dynamic property of the element; it's not a requirement that it serialize back to html. If this is being reported against IE, it's a duplicate of #769 / #3879.

Note: See TracTickets for help on using tickets.