Bug Tracker

Ticket #6293 (closed bug: wontfix)

Opened 5 years ago

Last modified 3 years ago

Selector ":hidden" collects selects options in IE, Opera and maybe Safari.

Reported by: pyhoster Owned by:
Priority: low Milestone: 1.next
Component: selector Version: 1.4.2
Keywords: hidden Cc: miketaylr
Blocking: Blocked by:

Description

It`s the same problem that was with "tr" tag - browsers (but not FF), calculates <option> size as zero (FF returns actual size of parent <select>). For my opinion "option" is not really hidden tag, so i make a little patch and attached it.

Attachments

css.js.patch Download (498 bytes) - added by pyhoster 5 years ago.
Patch to fix detection <option> as ":hidden"

Change History

Changed 5 years ago by pyhoster

Patch to fix detection <option> as ":hidden"

comment:1 Changed 4 years ago by miketaylr

  • Cc miketaylr added
  • Priority set to low
  • Status changed from new to open
  • Milestone changed from 1.4.2 to 1.4.5

Looking at  http://jsfiddle.net/8R2E8/, IE7,8,9Beta, Operas and Chromes all say that <options> are hidden. Firefox thinks they aren't.

comment:2 Changed 3 years ago by john

  • Status changed from open to closed
  • Resolution set to wontfix

Considering that every browser but Firefox says that it's hidden - it seems like it's the other way around. That being said, I'm not really sure what you're trying to achieve with :hidden/:visible on option elements. It seems like you should probably be using :selected instead. Don't think this is something that we're going to spend a lot of cycles on.

comment:3 Changed 3 years ago by john

#4740 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.