Bug Tracker

Ticket #4740 (closed bug: duplicate)

Opened 5 years ago

Last modified 3 years ago

:visible:selected or :visible:first selectors not working on IE6

Reported by: tipiirai Owned by: john
Priority: minor Milestone: 1.next
Component: selector Version: 1.3.2
Keywords: needsreview Cc:
Blocking: Blocked by:

Description

When I had two special selectors together the results won't work on IE6. Haven't tried on any other than those two yet. Here is my test page:

 http://flowplayer.org/demos/test/jquery3.htm

On FF it says: 456123 On IE6 it says: undefinedundefined

Change History

comment:1 Changed 5 years ago by tipiirai

After a bit of further investigation I realized that

:option:visible

is not working on IE. My test page has two visible option elements

 http://flowplayer.org/demos/test/jquery3.htm

IE does not found them.

comment:2 Changed 4 years ago by dmethvin

  • Status changed from new to open

comment:3 Changed 3 years ago by danheberden

  • Keywords needsreview added

IE6,7,8,9, Webkit and Opera all report 0. Firefox is the only one to report 2 in the test. I'm pretty sure this isn't a bug with jQuery, but rather, how Firefox is reporting the option nodes. I recommend a wontfix.

Possibly related: http://bugs.jquery.com/ticket/6233

comment:4 Changed 3 years ago by danheberden

  • Milestone changed from 1.4 to 1.next

comment:5 Changed 3 years ago by john

We should revisit this with the solution from #5020 (as confirmed in the triage meeting).

comment:6 Changed 3 years ago by john

#5020 is a duplicate of this ticket.

comment:7 Changed 3 years ago by john

  • Status changed from open to closed
  • Resolution set to duplicate

comment:8 Changed 3 years ago by john

Duplicate of #6293.

Note: See TracTickets for help on using tickets.