Bug Tracker

Modify

Ticket #5812 (closed enhancement: wontfix)

Opened 4 years ago

Last modified 3 years ago

Should look for =%3F in addition to =?

Reported by: harrisms Owned by: rwaldron
Priority: low Milestone: 1.5
Component: ajax Version: 1.4
Keywords: ajaxrewrite Cc:
Blocking: Blocked by: #8054

Description

The ajax function searches for =? in the data string to replace it with =jsonp..., but it does that *after* the data string is constructed by the param function, which uses encodeURIComponent to turn =? into =%F.

A quick fix is to modify the jsre regex to match =%3F too.

Change History

comment:1 Changed 3 years ago by rwaldron

  • Owner set to rwaldron
  • Priority changed from minor to low
  • Type changed from bug to enhancement
  • Status changed from new to assigned
  • Milestone changed from 1.4.1 to 1.5

comment:2 Changed 3 years ago by rwaldron

  • Keywords ajaxrewrite added

comment:3 Changed 3 years ago by jaubourg

  • Status changed from assigned to closed
  • Resolution set to fixed

Fixes #5812. =? will be detected even when it has been escaped during data serialization.

Changeset: 8c8bd3bf6ac982f98c1b89b0af74a1fd2d07e360

comment:4 Changed 3 years ago by jaubourg

#4920 is a duplicate of this ticket.

comment:5 Changed 3 years ago by jaubourg

  • Status changed from closed to reopened
  • Resolution fixed deleted

comment:6 Changed 3 years ago by jaubourg

  • Status changed from reopened to closed
  • Resolution set to wontfix
  • Blocked by 8054 added

This enhancement breaks legitimate uses of ? in url or data. The fix was reverted here  325dcdc

Last edited 3 years ago by jitter (previous) (diff)

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.