Bug Tracker

Ticket #4693 (closed bug: worksforme)

Opened 6 years ago

Last modified 15 months ago

Memory leak with framesets in modal dialog

Reported by: dberthia Owned by:
Priority: low Milestone:
Component: event Version: 1.3.2
Keywords: ie memory leak Cc:
Blocking: Blocked by:

Description

In IE6/7, jQuery 1.3.2 introduces a browser memory leak when opening a modal dialog window that contains a frameset. The leak is made worse if there are nested framesets in the popup window, and pages within the frameset include jQuery. See attached files to reproduce the problem.

Attachments

Leak.zip Download (21.3 KB) - added by dberthia 6 years ago.
Unzip and launch index.htm in IE6. Use Task Manager to monitor as you open/close the popup window.

Change History

Changed 6 years ago by dberthia

Unzip and launch index.htm in IE6. Use Task Manager to monitor as you open/close the popup window.

comment:1 Changed 5 years ago by dmethvin

  • Priority changed from critical to major
  • Milestone changed from 1.3.2 to 1.3.3

comment:2 Changed 5 years ago by vesech

Anxiously awaiting the outcome of this.

comment:3 Changed 5 years ago by dberthia

I'm heartened to see some activity on this. We had to remove jQuery from our modal dialogs because of this, which obviously seriously restricts us from a development standpoint.

comment:4 Changed 5 years ago by john

  • Component changed from unfilled to core

comment:5 Changed 5 years ago by dberthia

I'm now disheartened so see 1.4 roll out and still no activity on this.

comment:6 Changed 4 years ago by re076

Try this fix to 1.4.2

add to line 67: FSP change DOMContentUnLoaded,

add to line 756: FSP change DOMContentUnLoaded = function() { Original

for ( var id in jQuery.cache ) {

if ( jQuery.cache[ id ].handle ) { Try/Catch is to handle iframes being unloaded, see #4280

try {

jQuery.event.remove( jQuery.cache[ id ].handle.elem );

} catch(e) {}

}

}

FSP extension window.detachEvent( "onload", jQuery.ready ); window.detachEvent( "onunload", DOMContentUnLoaded ); window.jQuery = window.$ = jQuery = null;

}; FSP change end

change line 2627: if ( window.attachEvent && !window.addEventListener ) {

FSP change

window.attachEvent("onunload", DOMContentUnLoaded );

}

comment:7 Changed 4 years ago by SlexAxton

  • Priority changed from major to low
  • Status changed from new to open
  • Milestone changed from 1.4 to 1.5

Seems to still exist in 1.4.x - marking as valid.

comment:8 Changed 4 years ago by john

  • Status changed from open to closed
  • Resolution set to worksforme
  • Component changed from core to event

I believe that this has been resolved. Please re-open if that is no longer the case.

comment:9 Changed 4 years ago by alexgalp

I'm checked the attached test case on ie7 and 6 with jQuery 1.6.1 and the leak is still occurs.

comment:10 Changed 4 years ago by anonymous

The bug still happens! is it a dead end?

comment:11 Changed 4 years ago by rwaldron

#9462 is a duplicate of this ticket.

comment:12 follow-up: ↓ 13 Changed 4 years ago by rwaldron

#9471 is a duplicate of this ticket.

comment:13 in reply to: ↑ 12 Changed 4 years ago by r_ramasamy@…

Replying to rwaldron:

#9471 is a duplicate of this ticket.

I still see it in 1.6.1 and entered a ticket. I got reply as duplicate of #4693. what is the solution?

comment:14 Changed 15 months ago by anonymous

someone have a solution?

Note: See TracTickets for help on using tickets.