Bug Tracker

Ticket #1872 (closed bug: invalid)

Opened 7 years ago

Last modified 3 years ago

Charachter Encoding on Ajax Load

Reported by: eshu Owned by:
Priority: major Milestone: 1.2.4
Component: ajax Version: 1.2.1
Keywords: Cc:
Blocking: Blocked by:

Description

hello! i`ve just noticed that every time i use some of Jquery plugins that use Ajax load request witch loads some (.html) pages encoded other than default (utf-8, i guess) it renders in the end with error

for example i tried JTicker, UI Tabs, and every time i use Ajax load it ends up in mess.( character encoding for eastern europe windows-1250)

ive reported the authors about this bug and i concluded that i might report this to you instead (they told me that that is Jquery thing)

i hope in the future somebody will take some time and take care of this problem, because i find this libraries to be finest thing around and it would be ptty not to have support for character coding else than utf-8...

cheers!

mario

Attachments

jquery_test.html Download (959 bytes) - added by davidserduke 7 years ago.
test case
unicode.html Download (126 bytes) - added by davidserduke 7 years ago.
test case data 1
westeurope.html Download (31 bytes) - added by davidserduke 7 years ago.
test case data 2
.htaccess Download (117 bytes) - added by davidserduke 7 years ago.
test case data 3

Change History

comment:1 Changed 7 years ago by davidserduke

  • need changed from Review to Test Case

Is there a test case for this that displays the problem?

comment:2 Changed 7 years ago by davidserduke

May be related to #1931 and #1934.

comment:3 Changed 7 years ago by joern

  • Component changed from core to ajax

Changed 7 years ago by davidserduke

test case

Changed 7 years ago by davidserduke

test case data 1

Changed 7 years ago by davidserduke

test case data 2

Changed 7 years ago by davidserduke

test case data 3

comment:4 Changed 7 years ago by davidserduke

  • need changed from Test Case to Review
  • Status changed from new to closed
  • Resolution set to worksforme

This is a problem with you web server and not with jQuery. If you look at the test case (which worked for me), you'll see (if you use apache) the .htaccess file attached specifies which documents are delivered with what encoding. This should fix the problem you are seeing.

comment:5 Changed 7 years ago by eshu

  • Status changed from closed to reopened
  • Resolution worksforme deleted

sorry, i thought that this will remain unanswered...

yes i see now that i wasn't clear enough... i was testing ui-tabs, as well as other plugins LOCALLY on my pc, on different web browsers (Safari, IE,Opera,Safari/win) that was also happened when i upload files to web host, but the point is this was happened locally (default charachter encoding used on index page was/is utf-8- i changed that-nothing happened)

Windows XP with croatian characters enabled (keyboard as well)

so basically when i put some croatian characters in some test file witch is then (ajax) called by the

ui-tabs using jquery build in ajax call, it doesent present it corectly...(well in fact all characters are lost)

again, this is all happening locally!?!

if somebody finds a time, someday somewhere, is very much welcomed! :-)

this is big issue because the alternative is to use some iframe or object witch is pretty much inconvenient... thx! mario

comment:6 Changed 7 years ago by davidserduke

So do you have a test case? The only test case I was able to create I got to work. And what do you mean by locally? Are you loading the files directly ( file:///...) ? Or do you just mean the web server (apache/IIS) is running on the same machine as the browser?

comment:7 Changed 7 years ago by eshu

oh, sorry! i was thinking about that last night before goingto sleep! :-)

ok, i see, i dont know how to express my problem in right terms, so here we go with test case...

 http://eshu.110mb.com/ui.tabs/

ok, there it is, tabs one, two, three... i put some eastern european charachters in files (ahah_1.html, ahah_2.html,ahah_2.html) witch are called (? i dont know if this is are right term) by this script(ui.tabs) witch uses jquery

i was talking to the guy that kindly provided tbas and he told me that this is jquerry issue...

you can just check a bit, and tell me where the problem is, if its not in ajax call or whatever?

nevertheless thank you very much for dealing with this so far!

i appreciated it! :-)

p.s. as you can see in same folder i put also those test files you provided last time, but when i test them they are showing the same problems...ok im aware its a free web hoster with narrowed capabilities..

comment:8 Changed 7 years ago by eshu

i forgot to mention... :-) i uploaded those files with original character encoding set of utf-8... the same problems occurred when i put the file character encoding of windows-1250 ( witch i usually put on my files...) i've tested this also with windows-1250 char. enc. and i had the same issue...

thank you! :-)

comment:9 Changed 7 years ago by eshu

oh my god! i got it!!! i dont know how,but i got it now! well i know how, but i dont konw how that idea comes to me...i guess it has something to do with all this conversation.... :-)) im happy now it working! the issue was with my default web page editor ie Top styler... what i have done was just copy and paste original files (ahah_1.html, ahah_2.html,ahah_2.html) in notepad and before i close them i put encoding to UTF-8!... :-) i never knew it could be so simple...this was bothering me so much, year or so, and i have tried enything, and things get so complicated... i was going around thinking it has something to do with jquery or something else... so simple! thank you, anyway!!!!

i just hope this helps someone in future... so simple... :-)

comment:10 Changed 6 years ago by flesler

  • Status changed from reopened to closed
  • Resolution set to invalid
  • Milestone changed from 1.2.2 to 1.2.4
Note: See TracTickets for help on using tickets.