Bug Tracker

Modify

Ticket #1931 (closed feature: duplicate)

Opened 6 years ago

Last modified 6 years ago

.getScript misses charset property

Reported by: daditto Owned by:
Priority: minor Milestone: 1.2.2
Component: ajax Version: 1.2.1
Keywords: getScript charset wrong Cc:
Blocking: Blocked by:

Description

Hello,

It has come to my attention that there's no way to set script charset when calling .getScript function. It's a vital option when script charset differs from the page it's displayed on. In case no script charset specified, IE7 uses document charset to render script content. This is not acceptable sometimes.

I've made a dirty hack and set it manually to UTF-8 by adding script.charset="utf-8"; after line 2262 of jquery.js (var script = document.createElement("script");)

But I think jQuery should have a more elegant solution to have script charset configured.

Thank you, daditto.

Change History

comment:1 Changed 6 years ago by john

  • Component changed from core to ajax

comment:2 Changed 6 years ago by davidserduke

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #1934.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.