Bug Tracker

Ticket #14901 (closed bug: fixed)

Opened 8 months ago

Last modified 7 months ago

"Unsafe HTML" warnings in WWA

Reported by: dmethvin Owned by: gibson042
Priority: blocker Milestone: 2.1.1
Component: support Version: 1.11.0
Keywords: Cc:
Blocking: Blocked by:

Change History

comment:1 Changed 8 months ago by dmethvin

  • Priority changed from undecided to low
  • Resolution set to fixed
  • Status changed from new to closed
  • Component changed from unfiled to support
  • Milestone changed from None to 1.11.1/2.1.1

comment:2 Changed 8 months ago by dmethvin

  • Milestone changed from 1.11.1/2.1.1 to 2.1.1

Only needed on the 2.x branch since it's for WWA support, and cherry-picking it is pretty messy.

comment:3 Changed 8 months ago by dmethvin

#14913 is a duplicate of this ticket.

comment:4 Changed 8 months ago by anonymous

One of the two errors is gone in 2.1.1-beta1, but the other is still present.

div.innerHTML = "<select t=><option selected=></option></select>";

comment:5 Changed 8 months ago by dmethvin

  • Priority changed from low to blocker
  • Status changed from closed to reopened
  • Resolution fixed deleted

comment:6 Changed 8 months ago by dmethvin

  • Status changed from reopened to open

Thanks for catching this! Yes, Sizzle didn't get updated but it was fixed there.

 https://github.com/jquery/sizzle/pull/253

comment:7 Changed 7 months ago by gibson042

  • Owner set to gibson042
  • Status changed from open to assigned

comment:8 Changed 7 months ago by Richard Gibson

  • Status changed from assigned to closed
  • Resolution set to fixed

Selector: Update Sizzle to 1.10.19

Fixes #14901 Fixes #14793

Changeset: 90b43de21296cf59af7dd37c49c1a9a4f8483f68

Note: See TracTickets for help on using tickets.