Bug Tracker

Ticket #14798 (closed bug: fixed)

Opened 9 months ago

Last modified 8 months ago

Define bower.json#main for all tags

Reported by: rhys.evans@… Owned by: timmywil
Priority: high Milestone: 1.11.1/2.1.1
Component: build Version: 1.11.0
Keywords: Cc:
Blocking: Blocked by:

Description

I raised a bug with bower  https://github.com/bower/bower/issues/1118 asthe bower registry entry for lower case jquery no longer points to /components/jquery, but to jquery/jquery, which I'm told was done in response to a request from jquery.

It's a sensible move, but this breaks the build for a decent number of apps because we use browserify + debowerify, which relies on bower.json#main being properly defined (for jquery it should probably be ['dist/jquery.js', 'dist/jquery.min.js', 'dist/jquery.map']).

I'll bet debowerify isn't the only tool out there that makes use of bower.json#main. Can you please republish your tags with the main property defined and, in the meantime, ask bower to temporarily revert the url routing.

Change History

comment:1 Changed 9 months ago by kuraga333@…

+1. And I don't use browserify + debowerify. Just brunch build:

[Error: Component JSON file "/home/sasha/suitcase/client/bower_components/jquery/.bower.json" must have `main` property. See https://github.com/paulmillr/read-components#README]

comment:2 Changed 9 months ago by timmywil

#14814 is a duplicate of this ticket.

comment:3 Changed 9 months ago by timmywil

  • Owner set to timmywil
  • Priority changed from undecided to high
  • Status changed from new to assigned
  • Component changed from unfiled to build

comment:4 Changed 8 months ago by Timmy Willison

  • Status changed from assigned to closed
  • Resolution set to fixed

Bower: add main property, move Sizzle to devDependencies, add license property

Fixes #14798 Close gh-1516 Ref gh-1338

Changeset: 027d470b574e15c94cda28f5e2c7a0ed54c11fa6

comment:5 Changed 8 months ago by timmywil

Tags 1.11.0 and 2.1.0 have also been updated. Let us know if you have anymore problems.

comment:6 Changed 8 months ago by Timmy Willison

Bower: stop ignoring yourself, bower

Ref #14798 Ref gh-1516 Ref gh-1338

Changeset: a35996141e3c1de92e89ed77eac1799124e747d3

comment:7 Changed 8 months ago by dmethvin

  • Milestone changed from None to 1.11.1/2.1.1
Note: See TracTickets for help on using tickets.