Bug Tracker

Ticket #14717 (closed bug: cantfix)

Opened 9 months ago

Last modified 9 months ago

onbeforeunload doesn't work on iOS 6-7

Reported by: m_gol Owned by: m_gol
Priority: low Milestone:
Component: event Version: 2.1.0-rc1
Keywords: Cc:
Blocking: Blocked by:

Description

iOS doesn't seem to support the onbeforeunload event but window.onbeforeunload is null which makes our test suite believe it's supported and run the test. :(

This is the only test that's failing in iOS6, fixing/workarounding it would make it possible to register iOS6 in TestSwarm. (iOS7 fails more tests so that would come later).

I have no idea how to blacklist this test in Mobile Safari without resorting to UA sniffing.

Change History

comment:5 Changed 9 months ago by m_gol

  • Owner set to m_gol
  • Priority changed from undecided to low
  • Status changed from new to assigned
  • Component changed from unfiled to event
  • Milestone changed from None to 1.11/2.1

The problem is a support test would have to effectively trigger unload and if beforeunload is not supported there's no way to cancel the unload. :/

comment:3 Changed 9 months ago by Michał Gołębiowski

  • Status changed from assigned to closed
  • Resolution set to fixed

Tests: Blacklist beforeunload test in iOS

iOS has the window.onbeforeunload field but doesn't support the beforeunload handler making it impossible to feature-detect the support.

Fixes #14717 Closes gh-1496

Changeset: 988d99ad278c2c9dc16c68f86bddc4df99dcd928

comment:4 Changed 9 months ago by dmethvin

I'm thinking we may want to close this actual ticket as cantfix and we probably need somewhere to document this. That part is stumping me though, because a note in the API docs is likely to be overlooked. Perhaps Google will find this ticket.

comment:5 Changed 9 months ago by m_gol

  • Status changed from closed to reopened
  • Resolution fixed deleted
  • Milestone 1.11/2.1 deleted

comment:6 Changed 9 months ago by m_gol

  • Status changed from reopened to closed
  • Resolution set to cantfix

You're right, it's not fixed per se, I just blacklisted a failing test so that the build passes. Definitely cantfix.

Note: See TracTickets for help on using tickets.