Bug Tracker

Modify

Ticket #14047 (closed bug: fixed)

Opened 10 months ago

Last modified 10 months ago

$.data() can't retrieve data stored by .data() when key is hyphenated

Reported by: mcchen110 Owned by: rwaldron
Priority: low Milestone: 2.0.3
Component: data Version: 2.0.2
Keywords: Cc:
Blocking: Blocked by:

Description

$.data() can't retrieve data stored by .data() when key is hyphenated.  http://jsfiddle.net/ZwMsn/ the result should be "merlin", not undefined.

Change History

comment:1 Changed 10 months ago by rwaldron

  • Owner set to rwaldron
  • Status changed from new to assigned

comment:2 Changed 10 months ago by rwaldron

  • Status changed from assigned to closed
  • Resolution set to worksforme

comment:3 Changed 10 months ago by mcchen110

Sorry, i create the jsfiddle with the wrong version,it won't work when using 2.0.2,please see ticket#14048

comment:4 Changed 10 months ago by rwaldron

  • Status changed from closed to reopened
  • Resolution worksforme deleted

comment:5 Changed 10 months ago by rwaldron

  • Status changed from reopened to assigned

patch to follow

comment:6 Changed 10 months ago by rwaldron

#14057 is a duplicate of this ticket.

comment:8 Changed 10 months ago by Rick Waldron

  • Status changed from assigned to closed
  • Resolution set to fixed

Fixes #14047 jQuery.data should not miss data-* w/ hyphenated property names

http://bugs.jquery.com/ticket/14047 Signed-off-by: Rick Waldron <waldron.rick@…>

Changeset: 147726af127bce98b4e9dfe517d68f4a1ea0c1fc

comment:9 Changed 10 months ago by dmethvin

  • Milestone changed from None to 2.0.3

comment:10 Changed 10 months ago by dmethvin

  • Component changed from unfiled to data

comment:11 Changed 10 months ago by dmethvin

  • Priority changed from undecided to low

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.