Bug Tracker

Ticket #13983 (closed bug: fixed)

Opened 17 months ago

Last modified 13 months ago

Switch to //# for sourcemap directives

Reported by: dmethvin Owned by: m_gol
Priority: high Milestone: 1.11/2.1
Component: build Version: 1.10.1
Keywords: Cc:
Blocking: Blocked by:

Description

The  sourcemap r3 proposal has been changed at our request to avoid the issues from #13274. Since nobody recognizes //# at the moment we should give them a few months to update.

Change History

comment:1 Changed 17 months ago by dmethvin

  • Priority changed from undecided to low
  • Status changed from new to open
  • Component changed from unfiled to build
  • Milestone changed from None to 1.11/2.1

comment:3 Changed 16 months ago by dmethvin

#14063 is a duplicate of this ticket.

comment:4 Changed 16 months ago by dmethvin

  • Priority changed from low to blocker
  • Milestone changed from 1.11/2.1 to 1.10.2/2.0.3

Well, thanks Chrome for barfing out a warning. We'll need to change this immediately to prevent a barrage of duplicate tickets.

comment:5 Changed 16 months ago by dmethvin

#14065 is a duplicate of this ticket.

comment:6 Changed 16 months ago by Dave Methvin

  • Status changed from open to closed
  • Resolution set to fixed

Fix #13983. Switch to # for sourcemaps.

Normally we'd avoid doing this on a patch release, but Chrome Canary is spewing deprecation warnings already and that's generating bug tickets.

Changeset: d53ddc90c1f119fb9148a553443ef3fbc3f3cc99

comment:7 Changed 16 months ago by Dave Methvin

Revert "Fix #13983. Switch to # for sourcemaps."

Per the discussion here:  https://code.google.com/p/chromium/issues/detail?id=256636

Thanks to the Chrome team for the quick response!

This reverts commit d53ddc90c1f119fb9148a553443ef3fbc3f3cc99.

Changeset: 6e630fbbb19306e1914712502a2b22872e94ddad

comment:8 Changed 16 months ago by dmethvin

  • Status changed from closed to reopened
  • Resolution fixed deleted

comment:9 Changed 16 months ago by dmethvin

  • Priority changed from blocker to high
  • Status changed from reopened to open
  • Milestone changed from 1.10.2/2.0.3 to 1.next

comment:10 Changed 15 months ago by m_gol

  • Milestone changed from 1.next to 1.11/2.1

We can do it now, Chromium has implemented the change in v29:
 https://src.chromium.org/viewvc/blink?revision=151755&view=revision[[BR]]  http://omahaproxy.appspot.com/ (v29 has a higher revision number)
and both Firefox & WebKit implemented //@ in the same version as the change to //#.

comment:11 Changed 15 months ago by m_gol

(to be more precise, Firefox has implemented support for both pragmas in v24, Safari will have it starting from 6.1/7.0)

comment:12 Changed 15 months ago by m_gol

  • Owner set to m_gol
  • Status changed from open to assigned

comment:13 Changed 14 months ago by Michał Gołębiowski

  • Status changed from assigned to closed
  • Resolution set to fixed

Fix #13983. Switch to # for sourcemap directives.

Changeset: dfaee326e6605dc6d848c4c5022e39069d2cee65

comment:14 Changed 13 months ago by m_gol

#14433 is a duplicate of this ticket.

comment:15 Changed 13 months ago by timmywil

#14446 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.