Bug Tracker

Modify

Ticket #13974 (closed bug: fixed)

Opened 11 months ago

Last modified 10 months ago

Accessing XML attribute named "type" broken on IE 7

Reported by: derRaab Owned by: gibson042
Priority: high Milestone: 1.10.2/2.0.3
Component: selector Version: 1.10.1
Keywords: Cc:
Blocking: Blocked by:

Description

I ran into an issue with jQuery 1.10.1 on IE 7. Accessing the XML attribute named "type" with $.attr( "type" ) throws an error in the new function interpolationHandler(); Here's a little test HTML document:

<!DOCTYPE html><html><head></head><body>

<!--jQuery 1.10.1 in IE 7 throws SCRIPT450 (wrong number of arguments) error in function interpolationHandler(){}-->

<script src=" http://code.jquery.com/jquery-1.10.1.js"></script>

<script type="text/javascript">

var xmlString = '<list><item type="type-a" other="other-a"/><item type="type-b" other="other-b"/></list>';

var xml = $.parseXML( xmlString );

$( xml).find( "item" ).each( function() {

Always works

var otherValue = $(this).attr( "other" );

alert( otherValue );

jQuery 1.10.1 in IE 7 throws SCRIPT450 (wrong number of arguments) error in function interpolationHandler(){}

var typeValue = $(this).attr( "type" );

alert( typeValue );

});

</script></body></html>

USING JQUERY 1.9.1 WORKS JUST FINE!

Change History

comment:1 Changed 11 months ago by derRaab

I also tried to use jsFiddle but it seems not to work properly!

comment:3 Changed 11 months ago by gibson042

#13973 is a duplicate of this ticket.

comment:4 Changed 11 months ago by gibson042

  • Owner set to gibson042
  • Priority changed from undecided to high
  • Status changed from new to assigned
  • Component changed from unfiled to selector

Confirmed.

comment:5 Changed 11 months ago by Richard Gibson

  • Status changed from assigned to closed
  • Resolution set to fixed

Fix #13974: XML .attr("type") (cherry picked from commit adf30903182f6ab99e3490ceac5a8c37bc59e325)

Changeset: 0b7c44a1da3ed278e6f50a76c4075620ddb595ad

comment:6 Changed 10 months ago by dmethvin

  • Milestone changed from None to 1.10.2/2.0.3

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.