Bug Tracker

Ticket #13818 (closed bug: fixed)

Opened 19 months ago

Last modified 19 months ago

Creation of `col` elements inconsistancy

Reported by: nikolay.r.rusev@… Owned by:
Priority: high Milestone: 2.0.1
Component: manipulation Version: 2.0.0
Keywords: Cc:
Blocking: Blocked by:

Description

jQuery 2.0 introduce breaking change in how creation of col elements is handled.

  • $("<col />") - returns a col element
  • $("<col /><col />") - returns a colgroup that contains n+1 col elements

The following jsbin demonstrates the above/see the browser console/ -  http://jsbin.com/uturay/3/edit

Here is how it looks with jQuery 1.9.1 -  http://jsbin.com/ehefeg/1/edit

For me expected behavior should be as in 1.9.1 version or at least in both cases(for 1 col and 1+ col) to have consistent behavior.

Thank you!

Change History

comment:1 Changed 19 months ago by dmethvin

  • Priority changed from undecided to high
  • Status changed from new to open
  • Component changed from unfiled to manipulation
  • Milestone changed from None to 2.0.1

Looks like we need a new wrapMap entry for <col>.

comment:2 Changed 19 months ago by Oleg

  • Status changed from open to closed
  • Resolution set to fixed

Fix #13818: Add wrapMap entry for col element

Changeset: 3a6194076b8b7ab5a9d9f5e6ec602db2ab427d3e

Note: See TracTickets for help on using tickets.