Bug Tracker

Ticket #13809 (closed bug: fixed)

Opened 19 months ago

Last modified 19 months ago

Closure Compiler/YUI Compressor fail

Reported by: agm257@… Owned by: gibson042
Priority: undecided Milestone: 2.0.1
Component: attributes Version: 2.0.0
Keywords: Cc:
Blocking: Blocked by:

Description

Reproduce:

Go to :  http://closure-compiler.appspot.com/home

And paste the jQuery 2.0 source code -- there is a "Missing name after . operator" error.

Notes:

This is also seen in the command line versions of both Closure Compiler and YUI Compressor.

This occurs because neither Closure Compiler nor YUI Compressor support reserved words as property names, so "Sizzle.selectors.match.boolean" throws an error.

Change History

comment:1 Changed 19 months ago by gibson042

  • Status changed from new to open
  • Component changed from unfiled to attributes

boolean hasn't been reserved since ECMA-262 3rd edition, which I guess puts us in exactly the same boat as #12158 ("throws"). Any preference from the peanut gallery on Sizzle.selectors.match["boolean"] vs. Sizzle.selectors.match.bool?

comment:2 Changed 19 months ago by dmethvin

  • Milestone changed from None to 2.0.1

Let's change "boolean" to "bool" per the meeting.

comment:3 Changed 19 months ago by gibson042

  • Owner set to gibson042
  • Status changed from open to assigned

comment:4 Changed 19 months ago by Richard Gibson

  • Status changed from assigned to closed
  • Resolution set to fixed

Fix #13809: Avoid collisions with words reserved by any version of ECMA-262

Changeset: ad71f47b27f463c6952768c5ab2773ae15ffa745

Note: See TracTickets for help on using tickets.