Bug Tracker

Ticket #13569 (closed bug: cantfix)

Opened 22 months ago

Last modified 12 months ago

Unknown property 'box-sizing'. Declaration dropped.

Reported by: unveiled14@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.9.1
Keywords: Cc:
Blocking: Blocked by:

Description

Warning in Firefox console appears on page load when jquery is included. To recreate: include jquery in an otherwise empty html file and open in Firefox (19.0). Doesn't break anything, but it's annoying for a library to generate warnings that don't indicate that they originate from the library.

Change History

comment:1 Changed 22 months ago by dmethvin

  • Status changed from new to closed
  • Resolution set to cantfix

The CSS box-sizing property is real. Firefox should not warn about it. Please don't let the anal retentive crowd turn this into another #7535. Complaints can either go to /dev/null or here:  https://bugzilla.mozilla.org/show_bug.cgi?id=243412

comment:2 Changed 22 months ago by m_gol

Yeah; unfortunately, Mozilla people seem to think box-sizing is a bad idea (I strongly disagree, happily using * {box-sizing: border-box;} on my sites) and they don't IMHO pay enough attention to fixing its issues and removing the prefix.

There's not much we can do about it, though.

Also, if we paid attention to such warnings, we would be killed by Opera that complains about every single vendor prefixed property it doesn't recognize (and why should it? it's vendor prefixed, for Christ's sake!).

comment:3 Changed 21 months ago by m_gol

#13707 is a duplicate of this ticket.

comment:4 Changed 17 months ago by anonymous

I strongly disagree, happily using * {box-sizing: border-box;} on my sites

Your strong disagreement doesn't count for much if you're using that css anywhere under any circumstances.

comment:5 Changed 12 months ago by anonymous

Just pinging to say that after 9 & 1/2 years, the FF bug responsible for this looks to be only a few more months (optimistically, weeks?) away!

Note: See TracTickets for help on using tickets.