Bug Tracker

Ticket #13483 (closed bug: fixed)

Opened 22 months ago

Last modified 20 months ago

Issue with stop(true).slideDown() during slideUp()

Reported by: styu Owned by: ros3cin
Priority: high Milestone: None
Component: effects Version: 1.9.1
Keywords: Cc:
Blocking: Blocked by:

Description

The issue is when the submenu is in the sliding up state, and it is clicked again, it stops but is not being animated backwards (instead the submenus are jumping out but their container is keeping its current height - no jump with jquery 2.0.0.b1). Tested in Firefox and Chrome with the same result.

 http://jsfiddle.net/HuCmy/35/

Change History

comment:1 Changed 22 months ago by styu

There is a workaround for this issue, just need to call .hide() before calling .stop(true).slideDown(). But I still think that this is an issue and needs to be solved internally. Working example (thanks for  Brad M):  http://jsfiddle.net/HuCmy/37/

comment:2 Changed 22 months ago by ros3cin

I'm trying to check this issue. \o

comment:3 Changed 22 months ago by ros3cin

Your issue is indeed a bug. After you stop a slideUp() animation before it finish, and try to do a slideDown(), it won't go. I am looking into this problem, trying to figure out where is the error. I really wanna contribute to this. I started debuging on sunday.

I'm putting here another test case, more clean to understand, ok.  http://jsfiddle.net/rgkv8/5/

Last edited 22 months ago by ros3cin (previous) (diff)

comment:4 Changed 22 months ago by styu

I have an other issue with sliding in IE10, maybe related to this one, but I can't make a simplified test case yet. Basically the styles added by slideUp() remains on the element after it seems to be completely hidden, and the on complete event never fires. But this seems to be an issue in IE10 only. My workaround is to use only show() and hide() in IE10 instead of slideDown() and slideUp().

comment:5 Changed 22 months ago by ros3cin

Hey, styu! I made progress fixing the bug! But it is still in partial resolution. I'm working hard to get the issue done ( respectiong jQuery standards ), as soon as possible.

comment:6 Changed 22 months ago by timmywil

  • Priority changed from undecided to high
  • Status changed from new to open
  • Component changed from unfiled to effects

comment:7 Changed 22 months ago by ros3cin

timmywil, would you assign this one to me? I'll be sending a patch for you to check this week.

Also, the reason the submenus are jumping is due to this fix http://bugs.jquery.com/ticket/12846. When you stop the animation, the overflow attribute will be set to normal, causing the submenu to appear over other itens, it should stay as overflow hidden. I guess this makes another issue to fix.

Last edited 22 months ago by ros3cin (previous) (diff)

comment:8 Changed 22 months ago by timmywil

  • Owner set to ros3cin
  • Status changed from open to assigned

comment:9 Changed 21 months ago by ros3cin

I'm writing test

Last edited 21 months ago by ros3cin (previous) (diff)

comment:10 Changed 21 months ago by ros3cin

Hey, styu!

I've made the fix and asked the oficial jQuery to update with it. But I can already provide you jQuery with the changes I made.

 http://speedy.sh/6nySn/jquery.js

*If I'm not allowed to provide this link here, tell me, timmywil*

comment:11 Changed 21 months ago by dmethvin

#13370 is a duplicate of this ticket.

comment:12 Changed 20 months ago by Renato Oliveira dos Santos

  • Status changed from assigned to closed
  • Resolution set to fixed

Fix #13483. Let slideDown() work after stop(). Close gh-1205.

Changeset: ea5c22ec12e6a548b1ec2d7b0dcd9f71bea8d5dd

Note: See TracTickets for help on using tickets.