Bug Tracker

Modify

Ticket #13089 (closed bug: fixed)

Opened 16 months ago

Last modified 15 months ago

support adds zoom style to body in Chrome/Safari

Reported by: Zak Johnson <zakj@…> Owned by: Zak Johnson <zakj@…>
Priority: blocker Milestone: 1.9.1
Component: support Version: 1.9b1
Keywords: Cc:
Blocking: Blocked by:

Description

On any browser for which typeof div.style.zoom isn't undefined, body.style.zoom is set to 1. Unfortunately, (at least) Chrome 24 and Safari 6 seem to support that property. Test case:

 http://jsfiddle.net/nTx2d/

This is a regression from 1.8.3, introduced in  https://github.com/jquery/jquery/pull/1025.

Change History

comment:1 Changed 16 months ago by dmethvin

  • Owner set to Zak Johnson <zakj@…>
  • Status changed from new to pending

Does this cause any problem?

comment:2 Changed 16 months ago by Zak Johnson <zakj@…>

  • Status changed from pending to new

Confusion about who set the style and why. Aside from that, I don't know.

comment:3 Changed 16 months ago by timmywil

  • Priority changed from undecided to low
  • Status changed from new to open
  • Component changed from unfiled to support
  • Milestone changed from None to 1.9

It's unnecessary to set in Chrome and Safari at least.

comment:4 Changed 16 months ago by m_gol

Actually, Opera does support zoom, too (IMHO Firefox is the only significant browser that doesn't) but the style doesn't get applied there; what could be the reason?

comment:5 Changed 15 months ago by dmethvin

#13239 is a duplicate of this ticket.

comment:6 Changed 15 months ago by derek@…

This breaks the CSS grid in Chrome. Thanks for throwing a huge wrench in my already filled day.

comment:7 Changed 15 months ago by dmethvin

#13318 is a duplicate of this ticket.

comment:8 Changed 15 months ago by dmethvin

  • Priority changed from low to blocker
  • Milestone changed from 1.9 to 1.9.1

comment:9 Changed 15 months ago by dmethvin

See #13318 for other impacts.

comment:10 Changed 15 months ago by anonymous

Just including 'jquery-1.9.0.min.js' causes JS errors on Opera 12.12: 'Invalid value for property: zoom'

comment:11 Changed 15 months ago by dmethvin

The commit, for reference:

 https://github.com/jquery/jquery/commit/84629a9b876f6969777b43f3229b62b43bb624d2

We need to condition that by something that only applies in oldIE-land. There are a couple of support properties in the vicinity.

comment:12 Changed 15 months ago by Dave Methvin

  • Status changed from open to closed
  • Resolution set to fixed

Fix #13089. Only apply zoom to IE6/7 body.

Changeset: 219a1935eea509bf147a05ef9d47502d8230991d

comment:13 Changed 15 months ago by scott.gonzalez

zoom of doom goes kaboom?

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.