Bug Tracker

Ticket #12846 (closed bug: fixed)

Opened 2 years ago

Last modified 22 months ago

overflow:hidden is not removed when .stop() is called

Reported by: Ult Combo Owned by: mikesherov
Priority: low Milestone: 1.9.1
Component: effects Version: 1.8.2
Keywords: Cc:
Blocking: Blocked by:

Description

I'm aware that when animating the dimensions of a div, overflow:hidden is added to the element style in order to don't show scrollbars.

The overflow property is removed from the element style when the animation is complete. However, that doesn't happen when I call the .stop method.

 Normal behavior - Without .stop(), scrollbars are hidden while animating and restored to default after animation.

 Test case - trigger the div's mouseenter then mouseleave while it is animating to invoke the .stop() method, the overflow:hidden stays in the element style and scrollbars are gone for good.

Temporary workaround: Set overflow:auto !important; in the CSS when the div is supposed to have scrollbars.

Proposed patch: remove the added overflow:hidden from the element style when .stop() is invoked.

I'd suggest not adding the overflow property if the element already has one, but in that case it could break back-compat. Therefore simply restoring the overflow when .stop() is called as if the animation had completed should suffice.

Change History

comment:1 Changed 2 years ago by timmywil

  • Priority changed from undecided to low
  • Status changed from new to open
  • Component changed from unfiled to effects
  • Milestone changed from None to 1.next

This sounds really familiar, but I can't find a related ticket.

comment:2 Changed 2 years ago by timmywil

#12951 is a duplicate of this ticket.

comment:3 Changed 23 months ago by mikesherov

  • Owner set to mikesherov
  • Status changed from open to assigned

this one is as simple as changing anim.done to anim.always for the overflow sets. Will have a pull request shortly.

comment:4 Changed 22 months ago by Dave Methvin

  • Status changed from assigned to closed
  • Resolution set to fixed

Fix #12846. Restore overflow when animation is stopped.

Changeset: a6c358d04693c5746e1557a2660dfccb169ad831

comment:5 Changed 22 months ago by Dave Methvin

Fix #12846. Restore overflow when animation is stopped.

(Cherry picked from a6c358d)

Changeset: 3f9f2b1dbcefdafc5ef11f7deb222a3b6d8941d8

comment:6 Changed 22 months ago by dmethvin

  • Milestone changed from 1.next to 1.9.1
Note: See TracTickets for help on using tickets.