Bug Tracker

Modify

Ticket #12572 (closed bug: fixed)

Opened 19 months ago

Last modified 19 months ago

:contains breaks searching iframes v1.8

Reported by: chris@… Owned by: gibson042
Priority: blocker Milestone: 1.8.2
Component: selector Version: 1.8.0
Keywords: Cc:
Blocking: Blocked by:

Description

Issue: :contains referencing an iframe will not find a matching element (returns empty object). If used outside of an iframe it appears to work correctly.

jQuery Version: 1.7.2 works; 1.8.* breaks (including live github version)

Browsers: Tested in Chrome 21.0.1180.89 m and FireFox 14.0.1

Sample:  http://jsfiddle.net/VZHvj/

Change History

comment:1 Changed 19 months ago by gibson042

  • Owner set to gibson042
  • Priority changed from undecided to blocker
  • Status changed from new to assigned
  • Component changed from unfiled to selector
  • Milestone changed from None to 1.8.2

comment:2 Changed 19 months ago by Timmy Willison

  • Status changed from assigned to closed
  • Resolution set to fixed

Sizzle: account for external document contexts (such as iframes) in combinator checks. Fixes #12572.

Changeset: a44463f83fee385879535ec2b2b37f584bcdebbd

comment:3 Changed 19 months ago by gibson042

#12586 is a duplicate of this ticket.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.