Bug Tracker

Modify

Ticket #12392 (closed bug: fixed)

Opened 20 months ago

Last modified 18 months ago

Elements created from HTML strings have a parentNode

Reported by: dmethvin Owned by: rwaldron
Priority: blocker Milestone: 1.9
Component: manipulation Version: 1.8.0
Keywords: Cc:
Blocking: Blocked by:

Description

 http://jsfiddle.net/F4LVB/

This causes isDisconnected() to return the wrong answer. Seems to have been introduced in 1.7.

Change History

comment:1 Changed 20 months ago by dmethvin

  • Priority changed from undecided to blocker
  • Status changed from new to open
  • Component changed from unfiled to manipulation
  • Milestone changed from None to 1.8.1

comment:2 Changed 20 months ago by dmethvin

Impact on .before and .after is here:  http://jsfiddle.net/Dy4WG/8/

comment:3 Changed 20 months ago by dmethvin

  • Owner set to rwaldron
  • Status changed from open to assigned

comment:4 Changed 20 months ago by rwaldron

comment:5 Changed 20 months ago by dmethvin

  • Milestone changed from 1.8.1 to 1.9

Since this has been true for many versions I'm kicking it to 1.9 for meditation. We've already solved the regression with div reuse in jQuery.clean.

comment:6 Changed 18 months ago by Oleg

  • Status changed from assigned to closed
  • Resolution set to fixed

Elements created from html strings have a parentnode. Fixes #12392

Changeset: 18e7a53d15dadae24703178a87192104935551b4

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.