Bug Tracker

Modify

Ticket #12384 (closed bug: fixed)

Opened 20 months ago

Last modified 20 months ago

.after fails with table rows in IE9

Reported by: anonymous Owned by: dmethvin
Priority: blocker Milestone: 1.8.1
Component: manipulation Version: 1.8.0
Keywords: Cc:
Blocking: Blocked by:

Description

Fiddle:  http://jsfiddle.net/DyRCZ/9/.

It is not possible to add multiple HTML strings to be placed after a table row in IE9. Works fine on Chrome and should work according to the docs.

Change History

comment:1 Changed 20 months ago by timmywil

  • Priority changed from undecided to blocker
  • Status changed from new to open
  • Component changed from unfiled to manipulation
  • Milestone changed from None to 1.8.1

Confirmed, seems this is a regression. Might have to do with multiple arguments passed to .after.

git test case:  http://jsfiddle.net/DyRCZ/12/

comment:2 Changed 20 months ago by dmethvin

  • Owner set to dmethvin
  • Status changed from open to assigned

comment:3 Changed 20 months ago by Dave Methvin

  • Status changed from assigned to closed
  • Resolution set to fixed

Fix #12347 and #12384. Use a fresh div in jQuery.clean each time.

Regression was introduced in 22ad8723ce07569a9b039c7901f29e86ad14523c most likely because the clown who fixed http://bugs.jquery.com/ticket/4011 didn't add a unit test.

Changeset: b6a7d022eeb8c2cb0b065a311e53f9ea98554600

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.