Bug Tracker

Ticket #12346 (closed bug: fixed)

Opened 2 years ago

Last modified 2 years ago

fn.append not working correctly

Reported by: davidsvetlik@… Owned by: dmethvin
Priority: blocker Milestone: 1.8.1
Component: manipulation Version: 1.8.0
Keywords: Cc:
Blocking: Blocked by:

Description

Hi, I think it will be faster, if I just show you :-)

Try following fiddle and compare the results for 1.7.2 and 1.8 (first nbsp is missing in 1.8):  http://jsfiddle.net/td3yf/

---

Just in case, here's a script code from fiddle:

var $e = $('<span>e</span>'), $x = $('<span>x</span>');

$('div').append('&nbsp;', $e, '&nbsp;', $x);​

---

Thank you for your efforts, David Svetlik

Change History

comment:1 Changed 2 years ago by dmethvin

  • Priority changed from undecided to blocker
  • Status changed from new to open
  • Component changed from unfiled to manipulation
  • Milestone changed from None to 1.8.1

In 1.8.0 it works in Firefox, not in Chrome or Safari; it throws an error in IE9. Breaks in jQuery 1.3.2, works everywhere in between.

comment:2 Changed 2 years ago by dmethvin

  • Owner set to dmethvin
  • Status changed from open to assigned

comment:3 Changed 2 years ago by dmethvin

  • Status changed from assigned to closed
  • Resolution set to fixed

Fix #12347 and #12384. Use a fresh div in jQuery.clean each time.

Regression was introduced in 22ad8723ce07569a9b039c7901f29e86ad14523c most likely because the clown who fixed http://bugs.jquery.com/ticket/4011 didn't add a unit test.

Changeset: b6a7d022eeb8c2cb0b065a311e53f9ea98554600

Note: See TracTickets for help on using tickets.